?
Solved

Sharepoint 2010 search not working

Posted on 2011-02-10
9
Medium Priority
?
2,317 Views
Last Modified: 2012-05-11
Hi all,

I've got a Sharepoint 2010 application where the search isn't working. If you try to search for something it just says that no results were found, despite there clearly being results.

In the Sharepoint Central Admin tool search settings (Central Administration  Search Service Application: Crawl Log - URL ) the log shows the following error;

https://sp.mydomain.com 
Access is denied. Verify that either the Default Content Access Account has access to this repository, or add a crawl rule to crawl this repository. If the repository being crawled is a SharePoint repository, verify that the account you are using has "Full Read" permissions on the SharePoint Web Application being crawled.

However the account being used to search (Network Service) has full read permissions on the application;
(All zones)  Search Crawling Account  NT AUTHORITY\NETWORK SERVICE  Full Read  

The only thing that we have changed from the default setting is the Alternate Access Mappings where we changed the default http://hostname to https://sp.mydomain.com.

I've tried adding http://hostname back as the intranet option but that hasn't worked.

Any ideas ?

Olly
0
Comment
Question by:stonneway
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
9 Comments
 
LVL 38

Expert Comment

by:Justin Smith
ID: 34865366
Have you tried using a regular domain account to crawl (which is best practice)?

The "default" zone must use NTLM for authentication.
0
 
LVL 1

Author Comment

by:stonneway
ID: 34865660
Yeah, just tried that, but it didn't help. Waiting for another crawl shows that the errors remain

The default AAM shows....

 
https://hostname - Default - https://hostname
https://sp.mydomain.com - Internet - https://sp.mydomain.com 
 
0
 
LVL 38

Expert Comment

by:Justin Smith
ID: 34865675
And you are using Classic / NTLM authentication?
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 38

Accepted Solution

by:
Justin Smith earned 2000 total points
ID: 34865686
Also, you may need to disable loopback....

The second solution is easiest....

http://support.microsoft.com/kb/896861
0
 
LVL 1

Author Comment

by:stonneway
ID: 34865692
NTLM. That is, internally we don't need to log on....it just knows....like magic
0
 
LVL 1

Author Comment

by:stonneway
ID: 34868811
Well disabling the loopback made a massive difference. Most of the errors have gone and we now have search results. Thanks.

However we still have a few small errors;
************
http://hostname:80/my/person.aspx?accountname=mydomain/myadminaccount 
This item could not be crawled because the crawler could not connect to the repository. Local SharePoint sites 2/11/2011 7:40 AM

sps3://hostname/site$$$people/bucketid=1  
This item could not be crawled because the crawler could not connect to the repository. Local SharePoint sites 2/11/2011 7:40 AM

sps3://hostname/site$$$people  
This item could not be crawled because the crawler could not connect to the repository. Local SharePoint sites 2/11/2011 7:40 AM

sps3://hostname  
This item could not be crawled because the crawler could not connect to the repository.
*************

Certainly the first error about http://hostname is down to the fact that the site doesn't respond to HTTP requests on port 80, it's only HTTPS on port 443. Is there a way to tell the search interface not to search HTTP or to force it to use HTTPS instead?

Any ideas on the other ones?

Olly

0
 
LVL 38

Expert Comment

by:Justin Smith
ID: 34870613
Check your content sources, are they using the correct URL?
0
 
LVL 38

Expert Comment

by:Justin Smith
ID: 35177596
Update?
0
 
LVL 1

Author Closing Comment

by:stonneway
ID: 35736284
Havent resolved all errors but that was helpful
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Ready to improve network connectivity? Watch this webinar to learn how SD-WANs and a one-click instant connect tool can boost provisions, deployment, and management of your cloud connection.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I recently came across an issue with a MOSS 2007 deployment where access into some sub-sites were denied, even for the MOSS farm administrators. A bit of background to the setup of this MOSS farm; this was a three server setup, consisting of a fr…
A while back, I ran into a situation where I was trying to use the calculated columns feature in SharePoint 2013 to do some simple math using values in two lists. Between certain data types not being accessible, and also with trying to make a one to…
This course is ideal for IT System Administrators working with VMware vSphere and its associated products in their company infrastructure. This course teaches you how to install and maintain this virtualization technology to store data, prevent vuln…
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question