Got Cwrsync daemon working, but I am trying to set some variables in the rsyncd.conf file.

Got Cwrsync daemon working, but I am trying to set some variables in the rsyncd.conf file:  
here is my rsyncd.conf file:


use chroot = false
strict modes = false
hosts allow = *
log file = cygdrive/f/rsyncd.log
uid = 0
gid = 0

# Module definitions

[BackupArea]
path = /cygdrive/f/backup/test/%computerName% <---------- This is how I want it to work...
read only = false
transfer logging = yes

When I try to rsync I am getting this error:

@ERROR: chdir failed
rsync error: error starting client-server protocol (code 5) at main.c(1506) [sen
der=3.0.7]

Rsync daemon log states:

02/10 16:57:32 [280] rsync: chdir /cygdrive/f/backup/test/%computerName% failed
: No such file or directory

here is what I read in the rsncd.conf documentation:  
You may base the path's value off of an environment variable by surrounding the variable name with percent signs. You can even reference a variable that is set by rsync when the user connects. For example, this would use the authorizing user's name in the path:

    path = /home/%RSYNC_USER_NAME%

Any idea what this is not working?
AkostechAsked:
Who is Participating?
 
kloverConnect With a Mentor Commented:
Switch to DeltaCopy!  http://www.aboutmyip.com/AboutMyXApp/DeltaCopy.jsp

It is a GUI wrapper for Rsync that will do what you are trying to accomplish.
0
 
AkostechAuthor Commented:
this was my old Rsync command before setting up a daemon:

rsync  -v -rlt --progress --stats --delete "/cygdrive/v/SHARE/" "jaxback02::u/%computername%/SHARE/" 1>>

This worked perfectly.  I can't get it to work with the new setup using a daemin
0
 
AkostechAuthor Commented:
no one has an answer on using Dynamic modules in my rsyncd.conf?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.