Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

No sound from Firefox or IE

Posted on 2011-02-10
10
Medium Priority
?
577 Views
Last Modified: 2012-05-11
I have a user who is having a strange problem in which his sound works on his Windows Vista machine in every application except for his web browsers.

In Vista, when you have an open applicaiton that is playing audio, there is usually a seperate volume slider for the application, but when sound should be playing through his web browser (both IE 8 and Firefox 3), there is no volume slider in the Mixer.

We have tried uninstalling Flash for firefox and ie, uninstalling firefox, reinstalling firefox and both flash plugins to no avail.

Per a suggestion here: http://en.kioskea.net/forum/affich-22335-no-sound-on-internet
We tried importing the suggested registry values, which I believe is the driver mapping, and still no go.

Made the following reg change as well per the above link:
"[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\NodeCLSIDs\{95037DA1-6ED9-4B27-8CFF-9AD3DFB0B2F2}]

double click on 'Auto Insert" on the right side of the box.

Change the Value from "1" to "0" and click OK. "

He tried to do a system restore but could not because it said some files were missing.

Has anyone experienced this problem? Thanks so much for your time!
0
Comment
Question by:Vantegis
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 6

Expert Comment

by:ladiesnhan
ID: 34866759
If you are using IE, you could try running with "No Add-On's". This is an option that you can select by doing so:
Click Start -> All Programs -> Accessories -> System Tools, and then click Internet Explorer (No Add-ons).
If your problem stop's with just this, you should determine which add on is the cause, by re-enabling them one at a time.

If you are using Firefox:
In Windows, click Start, open the All Programs list, and navigate to the Mozilla Firefox folder. In the Mozilla Firefox folder, select Mozilla Firefox (Safe Mode). There are options there for reseting/ and disabling your add-on's specifically.
0
 
LVL 59

Expert Comment

by:LeeTutor
ID: 34866793
And if the above doesn't solve it, then it might be a startup program that is causing the problem.  You could try running in Safe Mode with Networking (press the F8 function key as the computer boots up and choose that option from the menu presented), and if it now works, then:  

In Windows 98/ME/XP/Vista/Windows 7, you can choose which programs are run at startup by using the Microsoft Configuration utility:  click on the Start button, choose Run, type in MSCONFIG (doesn't need to be all capitals), click OK.  Choose the Startup tab, deselect programs to run at startup by removing the check mark.  In Windows 9x/ME, you may need to disable just about everything except Explorer, ScanRegistry and SysTray.  In Windows XP/Vista/Windows 7, just click on the button for Disable All. Reboot and see if the problem goes away.  If it does then re-enable the startup programs one (or a few) at a time, reboot, and when the problem occurs again, there is your culprit.  If you have a great number of apps to narrow down on in trying to track down the culprit, do it instead by dividing up the loading programs into successively smaller halves:  disable half of them; if the problem doesn't go away, then the offending app is within the other half, so divide that group into half; or if the problem does go away, then the disabled group contains the offender, so again narrow down by dividing in half.  

In Windows XP/Vista/Windows 7: If the problem continues to come up with all startup programs disabled, then it is probably a driver or service.  You can click on the Services tab in MSCONFIG, click on the button for Hide All Microsoft Services, leaving only third-party services displayed, then try turning them off in the same way you did for startup programs.  Finally, if third-party services are eliminated from being the cause of the problem, you could try narrowing down on Microsoft services in the same way.
0
 
LVL 49

Expert Comment

by:Jackie Man
ID: 34879828
Have you tried to un-install antivirus software, remove flash plugin / addon and re-install flash plugin / addon and see whether there is any sound from IE8 or Firefox 3?
0
[Webinar] Lessons on Recovering from Petya

Skyport is working hard to help customers recover from recent attacks, like the Petya worm. This work has brought to light some important lessons. New malware attacks like this can take down your entire environment. Learn from others mistakes on how to prevent Petya like worms.

 
LVL 5

Expert Comment

by:Alex
ID: 34882507
hi

Search for the msacm32.drv on your drive and if not found copy it from another computer and paste it into system 32 folder .
Also ensure and verify that the msacm32.drv driver file is existing in C:\Windows\System32 folder. If the file is missing in that location, search for other copy of msacm32.drv in the computer, or copy that file from another system as well.

Alternatively install latest vista service pack
0
 

Author Comment

by:Vantegis
ID: 34888811
Ladiesnhan: I have run IE with no add-ins and firefox in safe mode, still reproduced the problem.

LeeTutor: I have tried booting the machine in safe mode w/ networking, but it does not start audio services. I can try disabling all startup entities, but the user is at a remote location and it is extremely difficult for me to walk him through config changes that require reboots, as I have to re-establish a remote session each time. This may be my only option though, as I'm running out of options.

Jackieman: I have not uninstalled AntiVirus software before uninstalling and reinstalling flash. Is this known to interfere?

Adaroc: I have verified that msacm32.drv is in the system32 folder.

Thank you so much for all the input. I will update with more info as it's available.
0
 
LVL 49

Expert Comment

by:Jackie Man
ID: 34889317
you need to uni-install anti-virus first -> restart computer -> re-install firefox -> re-install flash add-on
0
 

Author Comment

by:Vantegis
ID: 34907652
I had the user disable all startup entries and the problem was still present. We did not have time to disable all non-microsoft services, but we will try this next. Will update.
0
 

Author Comment

by:Vantegis
ID: 34918505
We disabled all startup entries and non-microsoft services, still no sound through web browser.I used the flash uninstaller tool from the Adobe website to remove flash player for ie and firefox, and reinstalled, still no go.

The only thing keeping me from uninstalling his antivirus software is that he is trying to find his license key. Once he finds it, we will try Jackieman's proposed solution.

I read on the adobe forums to try installing the following audio codecs: http://www.free-codecs.com/download/K_lite_codec_pack.htm

Apparently these codecs have repaired this problem for other users. Anyone ever heard of this?
0
 

Accepted Solution

by:
Vantegis earned 0 total points
ID: 34922574
I found a solution. Installed K-lite codec pack from http://www.free-codecs.com/download/K_lite_codec_pack.htm. After the codec pack installed, viola. Sound working in web browsers.

The K-lite installer fixes registry problems related to audio/video during installation, and it found tons of broken registry links, invalid entries, etc.

We had to click yes to fix about 20 problems, but after the install, we had sound back.
0
 

Author Closing Comment

by:Vantegis
ID: 34949962
I attempted all suggested troubleshooting steps with no success. Tried K-lite codec installation as recommended by another forum, and the problem was resolved.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I had to do a bit of research to find the answer to this question so I thought I'd share my results.  Due to our outdated mainframe systems, we need to downgrade IE9 to IE8 in order to stay compatible.  We also needed to downgrade Java.  In order to…
Ever visit a website where you spotted a really cool looking Font, yet couldn't figure out which font family it belonged to, or how to get a copy of it for your own use? This article explains the process of doing exactly that, as well as showing how…
This Micro Tutorial will demonstrate how to add subdomains to your content reports. This can be very importing in having a site with multiple subdomains.
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
Suggested Courses

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question