Solved

Wrong database showing up in "show sql query" section of crystal reports

Posted on 2011-02-10
8
1,395 Views
Last Modified: 2012-05-11
I have a report linked to a db called - sl_lis.  when you look Database --> Set Datasource Location, it shows the correct datasource.
However, if you click on Database --> Show SQL Query, it shows it's pulling info from our "Reports" db.

How do I fix this?  I know it's going off of Reports rather sl_lis because Reports only goes back to 2007 and the report i'm running is looking for data from 2006 and nothing's coming up.

Any help is greatly appreciated
0
Comment
Question by:CAHFS
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
8 Comments
 
LVL 101

Expert Comment

by:mlmcc
ID: 34867317
DO you have any filtering of the data?

mlmcc
0
 

Author Comment

by:CAHFS
ID: 34867347
yes, lots.  I even posted another question yesterday about this same report.  
0
 
LVL 101

Expert Comment

by:mlmcc
ID: 34867479
IS the 2006 data being filtered out?

mlmcc
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 

Author Comment

by:CAHFS
ID: 34867481
no, it really shouldn't be.  in fact, I just created a quick mock-up of the same report and it found cases from 2006.
0
 
LVL 101

Expert Comment

by:mlmcc
ID: 34867514
Using the same filtering?

How did you change the database?

mlmcc
0
 

Author Comment

by:CAHFS
ID: 34867530
this report was going off of "Reports" when i first created it (months ago) but now that folks need to search data from earlier years, I clicked on Database --> set datasource location, and changed it.  Since the same tables exist in both db's, i thought it would be "simple", lol...
0
 
LVL 26

Accepted Solution

by:
Kurt Reinhardt earned 500 total points
ID: 34867605
Sometimes in Set Location, you have to explicitly set the location for every single table in the report, not just the global location.  My recommendation would be to open up set location again and set the location for each table.  See if this helps.

~Kurt
0
 

Author Comment

by:CAHFS
ID: 34867653
Ha!!!  Kurt, thank you!!!!   You'd think I would have thought to do that... two fields didn't match on one of the tables.

Thank you, thank you, thank you!!
0

Featured Post

On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I hate sub reports and always consider them the last resort in any reporting solution.  The negative effect on performance and maintainability is just not worth the easy ride they give the report writer.  Nine times out of ten reporting requirements…
Hot fix for .Net Crystal Reports 10.2.3600.0 to fix problems with sub reports running on 64 bit operating systems ISSUE: Reports which contain subreports fail with error "Missing Parameter Value" DEPLOYMENT SERVER OS: Windows 2008 with 64 bi…
In this video, viewers are given an introduction to using the Windows 10 Snipping Tool, how to quickly locate it when it's needed and also how make it always available with a single click of a mouse button, by pinning it to the Desktop Task Bar. Int…
Add bar graphs to Access queries using Unicode block characters. Graphs appear on every record in the color you want. Give life to numbers. Hopes this gives you ideas on visualizing your data in new ways ~ Create a calculated field in a query: …

622 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question