Solved

SQL 2008 backwards compatibility

Posted on 2011-02-10
14
754 Views
Last Modified: 2012-06-27
I have 2 application running on 2 different servers that i need to integrate.  The applications are called Connectwise and Kaseya.  In order for the integration to happen I need to install a small integration app on the Kaseya server that connects to the Kaseya SQL 2008 database.  The problem I'm having is that this app is not able to connect to the local SQL 2008 database - just gives me a generic connection error.  I've confirmed that the credentials are good and believe that the problem is happening because the app was designed for SQL 2005 and Kaseya is running on SQL 2008.  Having said all that, is there anything I can do on the SQL 2008 server to make it more backwards compatible?  I'm a SQL novice.  thanks!
0
Comment
Question by:menreeq
  • 7
  • 6
14 Comments
 
LVL 22

Accepted Solution

by:
8080_Diver earned 250 total points
ID: 34867366
What is the "generic connection error"?

The connctionstring cor the SQL Server 2005 "version" should be about the only thing that needs to be changed unless the SQL Server 2008 database is using some SQL Server 2008 spefici datatypes (e.g. Date or Time).

What is the language that the app is written in?  Is there a reason you believe that the app is SQL Server 2005 specific?
0
 

Author Comment

by:menreeq
ID: 34867404
Take a look at the screenshot below.  the database i want to connect to is local.  I can connect to the other SQL databases with it on other servers, just not the one that is local.  Unfortunately I don't know the language the app is written in.  I was guessing that it is only compatible w/ SQL 2005 because the instructions it comes with only referrence SQL 2005... being a SQL novice I just connected those dots.


 Error Screenshot
0
 
LVL 13

Assisted Solution

by:geek_vj
geek_vj earned 250 total points
ID: 34868852
Please check if SQL Server is configured to use Mixed Authentication. You can check this by going to Management Studio --> Right click on the server --> Properties --> Security --> Check if the 'SQL Server and Windows Authentication Mode' is selected on the right. If not, please select it and restart SQL Services to get into effect.

Hope this helps!
0
 
LVL 22

Expert Comment

by:8080_Diver
ID: 34871850
Check to make sure that the service for your local SQL server Instance is actually running.  You should probably have a little icon that looks sort of like a computer tower in the lower right corner of the screen.

Also, did you install SQL Server Express on your local box and is that the server you are targetting?  

If you installed SQL Server Express on your box, then it is very probably that you will need to specify the server/instance for the database instead of (local) and the key pieces are probably nameof yourbox/SQLExpress.
0
 

Author Comment

by:menreeq
ID: 34872869
Thanks, I've confirmed that mixed authentication is on and that SQL services are running.  I'm using SQL 2008 not SQL express.  thanks
0
 

Author Comment

by:menreeq
ID: 34873039
I forgot to mention in my previous post that I'm still having the problem... sorry
0
 
LVL 22

Expert Comment

by:8080_Diver
ID: 34874018
When you connect to the server via Management Studio, what do you put in the Server Name, Authentication, and (if necessary) User Name and Password?
0
Free Gift Card with Acronis Backup Purchase!

Backup any data in any location: local and remote systems, physical and virtual servers, private and public clouds, Macs and PCs, tablets and mobile devices, & more! For limited time only, buy any Acronis backup products and get a FREE Amazon/Best Buy gift card worth up to $200!

 

Author Comment

by:menreeq
ID: 34874047
Server name is (local), authentication is SQL Server Authentication and I use the SA password to login.  Same stuff I use in the app.  thx
0
 
LVL 22

Expert Comment

by:8080_Diver
ID: 34874951
Okay, based on both the fact that you are attempting to use the SA login and the fact that the screen print yu provided mentions using a SQL Server login, I have to assume that the application relies on Server Authentication.  So, we're back to a question you never really answered: Do you know that the SQL Server instance is running on your box?  (Again, do you see the little computer tower icon in the lower right corner?)
0
 

Author Comment

by:menreeq
ID: 34875220
I don't see a little computer tower icon in the lower right corner but i think that's just how it is with SQL 2008 and Server 2008.  I'm sure that the instance is running because i do have people using the database  w/out a problem.  thanks
0
 
LVL 22

Expert Comment

by:8080_Diver
ID: 34875712
Are they using the database on your box?

Can you go to another box and set up the software so that it can access your original box?  Or, can you access the database using the sa login from another box using Management Studio?
0
 

Author Comment

by:menreeq
ID: 34909376
Well, I ended up contacting the vendor and they were able to somehow make it work... not exactly sure how.  What's the fair thing to do here?  I appreciate your time in answering my question, what do you suggest in terms of awarding points etc?
0
 
LVL 22

Expert Comment

by:8080_Diver
ID: 34918689
menreeq,

Well, of course, I want max points and an A rating. ;-)  Seriously, though, whatever you think nmy input was worth is what you should award.  I am mostly here to try to help (and, thereby, learn).
0
 

Author Closing Comment

by:menreeq
ID: 35030019
A solution was not provided by the answers but the effort is greatly appreciated.
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Suggested Solutions

There have been several questions about Large Transaction Log Files in SQL Server 2008, and how to get rid of them when disk space has become critical. This article will explain how to disable full recovery and implement simple recovery that carries…
SQL Server engine let you use a Windows account or a SQL Server account to connect to a SQL Server instance. This can be configured immediatly during the SQL Server installation or after in the Server Authentication section in the Server properties …
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now