Link to home
Start Free TrialLog in
Avatar of MisUszatek
MisUszatekFlag for United States of America

asked on

Error: No dsml attribute matching mvAttribute value

I am getting this error (No dsml attribute matching mvAttribute value) when trying to configure Synchronization Connections to my AD on SP 2010 installed on 2008 R2 server on a VM. Any idea what is wrong here? I am also getting this error in my logs (maybe it is related?)

==========================
Log Name:      System
Source:        Microsoft-Windows-DistributedCOM
Date:          2/10/2011 4:20:43 PM
Event ID:      10016
Task Category: None
Level:         Error
Keywords:      Classic
User:          NETWORK SERVICE
Description:
The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID {000C101C-0000-0000-C000-000000000046}
 and APPID {000C101C-0000-0000-C000-000000000046}
 to the user NT AUTHORITY\NETWORK SERVICE SID (S-1-5-20) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.
==========================
ASKER CERTIFIED SOLUTION
Avatar of Doug
Doug
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of MisUszatek

ASKER

Amazing response!!! I wish all answers would be like that. Before assigning points quick question: why do I need to do that? Is it because I installed IIS as a local admin only? Thanks
Yes, this happens when the SharePoint service accounts don't have the necessary permissions (Local Activation to the IIS WAMREG admin service).  When you installed SP as a local admin, that user may not have had the appropriate rights to the rest of the farm and it's spiderweb like tangents.  Glad you liked the response.  Good luck with SP 2010.  I hope it's everything Microsoft's touting it to be. :-)
Thanks again!
One of the best answers I ever got here!