• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 521
  • Last Modified:

Alert doesn't work if I enable metadata and versioning control.

Hi Experts,

We are working with SharePoint 2010 and we use metadata and version control on all libreries. The alert is not working in this scenario. I created a new library and the alert works without problem. As soon as I enabled metadata and version control on teh new library; the alert stopped working. Any ideas?

Thanks, Claudio
0
lwdcm
Asked:
lwdcm
  • 4
  • 3
1 Solution
 
Minesh ShahSharePoint & all about itCommented:
disagree.
tell me how you enable metadata and version control and
how you create alerts.
0
 
lwdcmAuthor Commented:
Hi MineSharePoint

Please see below:

1)Create a new Library
2)Select it
3)Ribbon - Library Tools
4)Library Settings
5)Versioning Setting
     a. Document Versioning history (major and minor)
     b.OK
6)Advanced Settings
7)Content Type
     a. Allow Management Content Type = Yes
     b.OK
Note: Term, Term Sets and Different content type are defined at Site Level
8)Content Type Section
      a.Add content type from site level
9) Go back to the new library
10) Ribbon - Library Tools
11) Pull-down Alert Me.
12) Set alert in this library
13) Receive the email tell that the alert is set.
14) Pull-down Alert Me.
15) Manage my alerts.
16) The the alert is on the Immediate section with delivery type = email

I hope it's help.

Claudio
 
0
 
Minesh ShahSharePoint & all about itCommented:
delete the existing alert and set up the new one.

also you may try:
verify: on index server, start > run > services.msc check simple mail transfer protocol is running.
(restart it).
verify: central admin > outgoing mail settings.

also try creating same kind of alert on some other site collection in same farm.
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

 
lwdcmAuthor Commented:
"delete the existing alert and set up the new one."
I did before several times, with no luck.

verify: on index server, start > run > services.msc check simple mail transfer protocol is running.
(restart it).
verify: central admin > outgoing mail settings.
.
I always received notification of enrolment right away. Also If I select "Email Document Link" always works; therefore I assume that the outgoing email settings and the services related with the email delivering works.

also try creating same kind of alert on some other site collection in same farm.
Sorry, Only one server in the farm with one top level site collection. But i will create a test one.

If I create an alert on a list -e.g. Discussion board- I always received the alert after five minutes.

If I create a new library without enabling metadata and versioning. The alerts works fine - again I received the email after five minutes.
0
 
lwdcmAuthor Commented:
Unbelievable!!!
http://social.msdn.microsoft.com/Forums/en-US/sharepoint2010setup/thread/624caaef-132f-41c3-8d5e-84a57ee35511

In my case I use four term set per content type......

The server has the latest fixes... any workaround.
0
 
Minesh ShahSharePoint & all about itCommented:
i think this is a deviation from what you asked in ur question, close the question and put above query as a fresh question.
0
 
lwdcmAuthor Commented:
I found it myself
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now