How do I get rid of the debug information in an EXE

In Delphi 2009 I enabled all the debugging features including "Include remote debug info" which made my .EXE jump from around 8MB to over 20MB.  After debugging I set it all back to normal but the .EXE when I build it is still over 20MB.  No idea what I am doing wrong here.

Here are my settings:
http://www.calfinated.com/dc1.jpg
http://www.calfinated.com/dc2.jpg

Thanks in advance!
DSOMAsked:
Who is Participating?
 
DSOMConnect With a Mentor Author Commented:
I tried everything here to no avail.  Then on a whim I clicked on "Configuration manager" and I saw that the active setting was still debug.  I made release the active setting and re-built and it finally worked!

0
 
systanCommented:
After changing something, and if you feel its a final configuration?, check the Default CheckBOX; Quit Delphi; then Open it again, try to compile your new project.
0
 
jimyXCommented:
Below is the default settings as it appears in my Delphi 2009:

Default-Settings-1.JPG
Default-Settings-2.JPG
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

 
Geert GOracle dbaCommented:
you need to build (= full compile) your project after changing options like compiler settings

there is no check for changes in options, so you don't get a different exe when compiling as normal

Hit Shift-F9: Rebuild Project
0
 
Geert GOracle dbaCommented:
btw,
no need to restart delphi
0
 
systanCommented:
good
0
 
DSOMAuthor Commented:
I was able to find the solution on my own.  Hopefully this will help others!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.