[Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Windows Server 2003 RDP not connect

Posted on 2011-02-11
11
Medium Priority
?
542 Views
Last Modified: 2012-05-11
I have a Windows Server 2003 Enterprise Edition server as one of my
domain controllers. I have Remote Desktop enabled on it for the domain
admin account. Port 3389 is opne and I also enable the options for RDP. It has two Ip address and i can ping both on server name and the IPs and its showing reply.

But I am not able to connect it from  a XP system which is on different domain. I receive the error

--------------------------------------
Remote Desktop Disconnected

The computer can not connect to the remote computer.

The connections was lost due to a network error. Try connecting again. if the problem continues, contact your network administrator or technical support

--------------------------------------

Is it not possible to connect the server from a XP system which is on a different domain. i do not want to add the XP system on Server's domain.

Please suggest.

Thanks
0
Comment
Question by:technicalsys
  • 5
  • 2
  • 2
  • +2
11 Comments
 
LVL 12

Expert Comment

by:enachemc
ID: 34868886
try to do a telnet to those IPs on port 3389
If it connects, it's not a network problem.
0
 

Author Comment

by:technicalsys
ID: 34868910
Hi enachemc,

When I telnet both the IP from the command prompt it is not showing anything. Only it is showing connecting to Ip and then disappears.

Thanks
0
 
LVL 5

Expert Comment

by:danubian
ID: 34868980
It is unusual to have a multi-homed DC.

Try open Terminal Services Configuration - RDP-TCP Properties - Network adapter tab
Select here the right network adapter, and from client side connect to this enabled IP.
0
Restore individual SQL databases with ease

Veeam Explorer for Microsoft SQL Server delivers an easy-to-use, wizard-driven interface for restoring your databases from a backup. No expert SQL background required. Web interface provides a complete view of all available SQL databases to simplify the recovery of lost database

 
LVL 8

Expert Comment

by:afthab
ID: 34869661
hi,

1. RDP should be enabled
2. Make sure Firewall disabled on server.
3.Check your TCP/IP settings (* subnet mask)
4. Try to connect through console (mstsc.exe /console)
5.Check event viewer for detaild error


If you need to access any resources from different domain, you should have trust relation to be created between the domains. If you already have trust relation created, then you should get both the domain option (Under logon to) while you are log in to the server.
0
 
LVL 19

Expert Comment

by:PeteJThomas
ID: 34870153
It is absolutely possible to do this. In fact, you don't NEED a trust relationship either, unless you want to be able to RDP on to a server in DomainB using an account in DomainA - We don't do this, we just connect to the 'other domains' using credentials from that domain (so we connect FROM DomainA, to servers in DomainB, by just providing valid credentials from DomainB).

Regardless, it sounds as if you're not even reaching that stage? Have you configured default credentials in the RDP connection, or are you doing this manually, and not even being prompted for credentials before the error appears?

The telnet command you tried was SUCCESSFUL - That is what telnet does when it successfully connects, if it failed it would give you an 'Unable to connect to xxxx on port xx' type error. If it just sits at a blank screen with a flashing cursor, it has connected successfully, so the port IS open.

Pete
0
 

Author Comment

by:technicalsys
ID: 34887436
Hi,

I have done the manual configuration of RDP console. I can still connect to the second server through run command by typing the server's ip address but not able to connect through RDP.

0
 
LVL 5

Expert Comment

by:danubian
ID: 34887491
Any related events on the target server's event viewer ?
0
 

Author Comment

by:technicalsys
ID: 34903565
Hi,
There was no error reported on the event viewer related to RDP.
0
 
LVL 8

Expert Comment

by:afthab
ID: 34903631
I hop you are using proper tcp/ip settings, did u tried my suggestions on above post ?

* did you restarted the server ?
* Enable and disable all tcp/ip and rdp settings, Then try

have a look
http://www.windowsnetworking.com/articles_tutorials/Troubleshooting-Remote-Desktop.html

AtB
0
 

Accepted Solution

by:
technicalsys earned 0 total points
ID: 34948691
Hi,

Resolved the issue by deleting the Certifica key from HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\TermService\Parameters.

Thanks for your help.
0
 

Author Closing Comment

by:technicalsys
ID: 34986626
Resolve the issue after editing the Registry
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

by Batuhan Cetin Within the dynamic life of an IT administrator, we hold many information in our minds like user names, passwords, IDs, phone numbers, incomes, service tags, bills and the order from our wives to buy milk when coming back to home.…
While rebooting windows server 2003 server , it's showing "active directory rebuilding indices please wait" at startup. It took a little while for this process to complete and once we logged on not all the services were started so another reboot is …
Are you ready to place your question in front of subject-matter experts for more timely responses? With the release of Priority Question, Premium Members, Team Accounts and Qualified Experts can now identify the emergent level of their issue, signal…
With just a little bit of  SQL and VBA, many doors open to cool things like synchronize a list box to display data relevant to other information on a form.  If you have never written code or looked at an SQL statement before, no problem! ...  give i…

865 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question