Solved

Correct way to control system folder in Windows 7

Posted on 2011-02-11
13
1,191 Views
Last Modified: 2012-05-11
This is an example of the problem:

I have used a tried and trusted compression program for years and, on reinstalling my Win 7 64 bit system earlier this week, I wanted to do what I do every time I rebuild windows and drop the Zipit and Zipit32.dll into the System32 folder and register ZIPIT.DLL with REGSVR32.

Couldn't do it. No amount of CMD windows with escalated priveleges, even in Safe Mode, would allow Windows to "see" the file. It failed every time with the error message that it couldn't load the file and the file didn't exist.

This, despite the fact that, prior to the rebuild the file was right there and allowed me to register it. Don't remember having to do anything special to achieve that.

The first time I played with Windows 7, I had to wrestle it to the ground in order to force it to comply. I "took ownership" of everything on the system and only then would it allow me to do what I needed to do. That worked but caused serious problems down the road. (The notorious nested Appdata folders being the worst)

So, this time I don't want to force it and, for that particular file, it doesn't even matter. I can put it wherever I like and register it with no problem. Hence I'm not under any pressure to get a solution so I thought I'd take this opportunity to find out how to get around such obstacles "the right way".

If you want other examples of my running battle with Windoze, see my previous question on "How to Delete an Unused Pagefile" (http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/Windows_7/Q_26612818.html)

Anyway, for 500 points, what I want to know is what either I'm doing wrong or what could be wrong with my setup to allow a situation in which even an administrator operating in safe mode with elevated rights can fail to register a previously registered and perfectly normall dll.


0
Comment
Question by:mjacobs2929
  • 5
  • 5
  • 2
  • +1
13 Comments
 
LVL 12

Expert Comment

by:John Griffith
ID: 34870220
Activate the Hidden Admin account and try REGSVR32 -

http://sysnative.com/0x1/Hidden_Admin_Acct.html

If still no-go, check in the Virtual Store - the file may be there -

C:\Users\<username>\AppData\Local\VirtualStore

http://support.microsoft.com/kb/927387

Regards. . .

jcgriff2
0
 
LVL 20

Expert Comment

by:Iain MacMillan
ID: 34870668
as long as you haven't grabbed any ownership of files/folders from the Trusted User account, you should be able to copy files into the System32 folder as long as you have local or domain admin rights.  that said the UAC will ask you to confirm as its requires manual approval.  technically i think you can have the DLL's in a temp folder and still register them, but i would make sure they are suitable for Win 7.

once done, you should be able to run a privileged command prompt to register the DLL's.  Personally if you don't have a WinZip v15 license, 7-Zip v9.20 is probably the next best compression program and its free - you just need to tell it to handle all compressed files within Win 7.

http://www.7-zip.org/
0
 

Author Comment

by:mjacobs2929
ID: 34878857
@jcgriff2
Damn! I thought I'd hit paydirt with your suggestion. I've seen refs to the Hidden Admin account before but never actually found the way to activate it on Win 7 or realised that it was potentially useful in this situation.

So I tried it. First problem - it expected a password. I didn't even know the account existed so obviously I didn't know the password and was surprised to find it had one. So - subsidiary question - Does anyone know if there is a default Admin password set by Microsoft and what it may be??

Anyway, tried my own password. Negative. Logged back in as myself, went to the User Accounts and changed the Admin password there, logged back in to the now visible admin account with the new password with no problems. After waiting the obligatory few minutes while it created an entirely unnecessary desktop, I created an elevated privelege cmd window, copied the relevant files into the System32 folder, ran Regsvr32 and...

Nada. Exactly the same response (Failed to load, file not found)  Oh, and the files are definitely right there where they should be. Not in the virtual store or any other folder.

@IainNIX
I know what I SHOULD be able to do. But I clearly can't!

On compression programs: I do use about 4 including the 2 you mention and, because you don't need a licence for 7z, that is the one I now integrate with my own software. However, I have some applications I wrote many moons ago which still use ZIPIT, hence my need for that.

In any case, the issue is not which compression tool to use, it's how to gain control of the system folders so that you can use any files you want, subject of course, to their compatibility with the OS (which ZIPIT still is by the way)
0
 
LVL 20

Expert Comment

by:Iain MacMillan
ID: 34886542
the admin account can be controlled by default from the Computer Management tool in Admin Tools folder.  By default all Win 7 local admin accounts are disabled.  Unlike XP's pre-build setup, Win 7 doesn't ask for a local admin setup/password, so if its been set and not blank, then the only way to reset it is from your own admin account, via the CM tool, under Local Users & Groups\Users.  Don't think it will make much difference, an admin account, is an admin account, unless yours in corrupted or compromised in some way.

tried looking at your ZIPIT app, but there seems to be so many with the same name.  i assume it does not have a normal installer wrapper, and has to be done manually.  i found v2.0 from mid-2010, but it has an EXE, some PYD files and a Python DLL/Library ZIP file.
0
 

Author Comment

by:mjacobs2929
ID: 34886805
this is off topic but I still don't understand how the admin account could acquire a password if it's never been used. Resetting it was trivial. I'm merely interested in how it got one at all (and what the hell it might have been!)

Back on topic, please don't get hung up on the ZIPIT. That's merely an example, as of now I cant manually register ANY file using REGSVR32 if it's in the system32 folder. ZIPIT is just the file I discovered the problem with. That's the real issue - regaining control - without screwing up the ownership - of that folder.
0
 
LVL 20

Expert Comment

by:Iain MacMillan
ID: 34895164
if its an oem based system ,  you or someone may have been asked to choose a local admin pwd.

as for the DLL's, can you copy them ok to the System32 folder?  Mind there are 2 versions of REGSVR32 if you have a 64 bit system:
    * The 64-bit version is %systemroot%\System32\regsvr32.exe.
    * The 32-bit version is %systemroot%\SysWoW64\regsvr32.exe.

Which one were you running, and I'm assuming inside an elevated command prompt?  I can copy DLLs into mine, but get warned that i don't have normal rights and do i wish to continue and provide Admin permission for this action, click YES and its copies them.  Can you get this far???
0
Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

 
LVL 20

Expert Comment

by:Iain MacMillan
ID: 34895455
found this link to a helper app call RegSVrHelper - http://www.addictivetips.com/windows-tips/registerun-register-dlls-with-regsvrhelper-in-windows/

perhaps this might be of use.
0
 

Author Comment

by:mjacobs2929
ID: 34915089
I have downloaded the RegSvrHelper, not least because it's from a better trusted source than the "RegUnReg" tool I've used for years. But it doesn't do anything that you can't do manually and, thus, doesn't help with this problem.

You raise an interesting point with the different versions of RegSvr and your explanation is counter-intuitive. I'd have expected the 64 bit version to be in the SysWow64 folder and the 32 bit version in System32.

In any case, I'd like to try them individually but would first like to know how to identify which is which!
0
 
LVL 20

Expert Comment

by:Iain MacMillan
ID: 34917310
here is MS's official notes on the program and its error messages, including the 64/32bit locations:

http://support.microsoft.com/kb/249873
0
 

Author Comment

by:mjacobs2929
ID: 35011273
another unresolved windoze question. Close it please
0
 
LVL 7

Accepted Solution

by:
CSI-Windows earned 500 total points
ID: 35024073

There are two possible problems here.

First if zipit.dll provides context menus in Windows Explorer and it is a 32-bit DLL - it will no longer work on 64-bit because Windows Explorer is 64-bit and cannot load 32-bit DLLs.

If, however, zipit.exe (assuming the first one you listed is an exe) is the only thing that uses zipit.dll, then it is being blocked from finding the DLL due to 32-bit File redirection.  When zipit.exe says please load "C:\Windows\System32\zipit.dll" - Windows notices it is 32-bit and automatically and transparently changes the load request to c:\windows\SysWOW64\zipit.dll.  This is because windows can tell that zipit.exe is 32-bit.

Try this:

1

Copy zipit.exe and zipit.dll to C:\windows\SysWOW64\

2

Run c:\windows\sysWOW64\regsrv32.exe c:\windows\sysWOW64\zipit.dll

3

Check if the application works.
If this works, I'd love to find out by seeing my points jump by 500 ;)
0
 
LVL 7

Expert Comment

by:CSI-Windows
ID: 35024074
Just posted a very likely solution.
0
 

Author Closing Comment

by:mjacobs2929
ID: 35026102
well done squire. The points are yours!
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
windows update wont update on hp laptop???? 7 80
Runtime Error 2 28
Malware Exploit 5 87
Flashplayer.hta Download 1 30
New Windows 7 Installations take days for Windows-Updates to show up and install. This can easily be fixed. I have finally decided to write an article because this seems to get asked several times a day lately. This Article and the Links apply to…
If you get continual lockouts after changing your Active Directory password, there are several possible reasons.  Two of the most common are using other devices to access your email and stored passwords in the credential manager of windows.
This Micro Tutorial will give you a introduction in two parts how to utilize Windows Live Movie Maker to its maximum capability. This will be demonstrated using Windows Live Movie Maker on Windows 7 operating system.
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now