Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

SSAS Measure values not displaying in cube browser

Posted on 2011-02-11
4
Medium Priority
?
1,883 Views
Last Modified: 2016-02-14
Hi

Firstly I am new to developing udm cubes in SSAS so bear with me.

I have created a simple udm cube with 1 fact table, 1 time dimension, and a few regular dimensions.

In the Data Source View, I have developed a star schema with the fact table in the middle and relationships out to each of the dimensions with the fact as the source and the dimension as the target.

In the dimension browser, I can view the hierachies correctly also.

However when I deploy & process the cube, it runs through the process fine but when I goto browse the cube and pull in a dimension or measure its not displaying any values. I get the following (See file attached)

Now I did notice that in the processing (which I set to ProcessFull for now) that it is processing the fact before the dimensions? Should it not be the other way around?

Please advise
Lisa udm-cube.docx
0
Comment
Question by:unawillers
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 37

Assisted Solution

by:ValentinoV
ValentinoV earned 750 total points
ID: 34887639
The dimensions should indeed be processed before the facts.  From the looks of your screenshot, it seems the dimensions are fine.  Try giving the facts a manual process.  (in SSMS, connect to your SSAS server, open the tree structure to see your cube, right-click the cube and select Process...)
0
 

Author Comment

by:unawillers
ID: 34888108
Hi

Thx for reply, unfortunely it made no difference...:-( am at a brick wall here so any help/suggestions would be greatly appreciated
0
 
LVL 2

Accepted Solution

by:
hariprasadrj earned 750 total points
ID: 34983235
When ever U process the cube make sure U click the reconnect option in the Cube browser so that it will be refreshed.
Measure groups will be processed first. Thats not a problem.
Make sure you did not set any Hierarchy visibility properties to false.
0
 

Author Closing Comment

by:unawillers
ID: 35241991
My issue was ultimately with the time dimension setup in the end. None of the answers provided alerted me to this. but they did prove helpful when working with ssas for the first time.
0

Featured Post

Ask an Anonymous Question!

Don't feel intimidated by what you don't know. Ask your question anonymously. It's easy! Learn more and upgrade.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article shows gives you an overview on SQL Server 2016 row level security. You will also get to know the usages of row-level-security and how it works
When trying to connect from SSMS v17.x to a SQL Server Integration Services 2016 instance or previous version, you get the error “Connecting to the Integration Services service on the computer failed with the following error: 'The specified service …
Using examples as well as descriptions, and references to Books Online, show the documentation available for date manipulation functions and by using a select few of these functions, show how date based data can be manipulated with these functions.
Via a live example combined with referencing Books Online, show some of the information that can be extracted from the Catalog Views in SQL Server.

604 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question