Solved

cisco 1800 wifi

Posted on 2011-02-11
3
550 Views
Last Modified: 2013-12-09
hello experts !

i`m new to configuring cisco wireless. the config i`ve pasted shows me connects wirelessly but never resolves an IP. could you let me know what i have done wrong please ? thanks !
Current configuration : 2352 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
!
!
ip cef
ip dhcp excluded-address 10.51.150.0 10.51.150.30
!
ip dhcp pool Vlan1
   import all
   network 10.51.150.0 255.255.255.0
   default-router 10.51.150.1
   domain-name XXXXX
   dns-server 10.51.150.10 10.51.150.11
   lease 4
!
!
ip domain name XXXXX
ip ips po max-events 100
no ftp-server write-enable
!
!
!
!
!
bridge irb
!
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface BRI0
 no ip address
 shutdown
!
interface Dot11Radio0
 no ip address
 !
 encryption vlan 1 mode ciphers tkip
 !
 ssid WiFi
    vlan 1
    authentication open
    authentication key-management wpa
    guest-mode
    wpa-psk ascii 0 XXXXXXXXXX
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
 54.0
 station-role root
!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Dot11Radio1
 no ip address
 shutdown
 speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0
 station-role root
!
interface FastEthernet0
 ip address dhcp
 duplex auto
 speed auto
!
interface FastEthernet1
 no ip address
 shutdown
!
interface FastEthernet2
 no ip address
 shutdown
!
interface FastEthernet3
 no ip address
 shutdown
!
interface FastEthernet4
 no ip address
 shutdown
!
interface FastEthernet5
 no ip address
 shutdown
!
interface FastEthernet6
 no ip address
 shutdown
!
interface FastEthernet7
 no ip address
 shutdown
!
interface FastEthernet8
 no ip address
 shutdown
!
interface Vlan1
 no ip address
 ip nat inside
 ip virtual-reassembly
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface BVI1
 ip address 10.51.10.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
bridge 1 route ip
!
line con 0
line aux 0
line vty 0 4
 login
!
no scheduler allocate
end

Open in new window

0
Comment
Question by:ravidhu
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 4

Expert Comment

by:gmooney7
ID: 34870763
You mean hosts cannot resolve an ip? Or the router cannot resolve an ip?  For the router to resolve, use this.

!primary ns
ip name-server x.x.x.x
!secondary ns
ip name-server x.x.x.x
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 34870911
The BVI interface should be in the same range and match the default router of fith DHCP scope

>interface BVI1
 ip address 10.51.10.1 255.255.255.0

>ip dhcp pool Vlan1
   network 10.51.150.0 255.255.255.0

Maybe just a simple typo on the BVI interface IP address? Shouldn't it be 10.51.150.1 ?
0
 

Author Closing Comment

by:ravidhu
ID: 34893649
thanks irmoore ! that fixed it.
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
For Sennheiser, comfort, quality and security are high priority areas. This paper addresses the security of Bluetooth technology and the supplementary security that Sennheiser’s Contact Center and Office (CC&O) headsets provide.  
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question