Solved

Install server administrator in esxi 4.1 machine

Posted on 2011-02-11
20
1,086 Views
Last Modified: 2012-05-11
I want to install a server administrator utility from Dell used for monitoring the server hardware. I read Dell instructions but i have a problem when i try to activate the uservars.CIMOEMProvidersEnabled  option in vmware. I can´t find this option in de esxi server. This option doesnt appear in advanced settings of the esxi server.
When i try to install through command line, i recieved this error: "Option UserVars.CIMOEMProvidersEnabled not found."
Please i need help.
0
Comment
Question by:k3pa
  • 7
  • 7
  • 6
20 Comments
 
LVL 118
ID: 34870873
0
 
LVL 28

Expert Comment

by:bgoering
ID: 34870877
Use UserVars.CIMoemProviderEnabled with lower case OEM, no s at end of Provider - there is typo in instructions
vicfg-advcfg -s 1 UserVars.CIMoemProviderEnabled <- full command

Good Luck
0
 
LVL 28

Expert Comment

by:bgoering
ID: 34870886
Of course that is through command line...
0
 
LVL 4

Author Comment

by:k3pa
ID: 34870934
Hi, i fixed the string but i get the same error.

Option UserVars.CIMoemProviderEnabled not found.

i put this command vicfg-advcfg.pl" --server 40.0.0.154 -s 1 UserVars.CIMoemProviderEnabled

Thanks
0
 
LVL 118
ID: 34870956
Check if you've got that option in Advanced Settings in vSphere Client?

Configuration, Advanced Settings, UserVars

 Configuration, Advanced Settings, UserVars
0
 
LVL 4

Author Comment

by:k3pa
ID: 34871005
Sorry but i havent got this option
I ve got an esxi 4.1.
thanks a lot.

error-vmware.JPG
error-vmware2.JPG
0
 
LVL 118
ID: 34871015
can you check under Misc?
0
 
LVL 28

Expert Comment

by:bgoering
ID: 34871042
Hmm, I don't see this on my 4.1 system either, maybe it was specific to 4.0 or the offline bundle created it. I am not running the Openmanage stuff on my Dell?

Did the vihostupdate step go ok? Did you reboot the server afterward? Are you using OM-SrvAdmin-Dell-Web-6.3.0-2075.VIB-ESX41i_A00.8.zip? http://support.dell.com/support/downloads/download.aspx?c=us&l=en&s=gen&releaseid=R275661&SystemID=pwe_r710&servicetag=10C1NM1&os=EX41&osl=en&deviceid=21859&devlib=0&typecnt=0&vercnt=1&catid=-1&impid=-1&formatcnt=0&libid=36&typeid=-1&dateid=-1&formatid=-1&source=-1&fileid=406735
0
 
LVL 28

Expert Comment

by:bgoering
ID: 34871063
What model is your server?
0
 
LVL 118
ID: 34871105
It's on mine!

But I've often seen it under Misc or UserVars on  don't know why it's different per system.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 28

Expert Comment

by:bgoering
ID: 34871119
Maybe its particular to if you install the Dell customized image? I am running the "stock" 4.1 image from vmware.
0
 
LVL 118
ID: 34871137
Yes, I'm using Dell or HP.
0
 
LVL 28

Expert Comment

by:bgoering
ID: 34871156
Seems like if the vihostupdate went correctly for the offline bundle it would create that uservar
0
 
LVL 28

Expert Comment

by:bgoering
ID: 34871160
I don't bother with openmanage because I only have a single Dell R710 host, everything else is HP or IBM
0
 
LVL 4

Author Comment

by:k3pa
ID: 34879095
I have seen under misc but does not appear in the misc option.
thanks.
0
 
LVL 118
ID: 34879136
What version of VMware ESXi 4.1 are you using|

e.g. from where and what did you download it from?
0
 
LVL 4

Author Comment

by:k3pa
ID: 34886545
i´m using 4.1.0 version. Build 260247
(VMware ESXi 4.1.0-260247.x86_64.iso)
I have downloaded it from vmware web.
thanks

0
 
LVL 118

Accepted Solution

by:
Andrew Hancock (VMware vExpert / EE MVE) earned 500 total points
ID: 34886958
0
 
LVL 4

Author Comment

by:k3pa
ID: 34886966
Hi all, i have installed this pack "Dell OpenManage Offline Bundle and VIB for ESXi" on my esxi server, but in the server administrator doesnt apear correctly, because ¡i doesn`t not display any data on the server on my ESXi server.
Use the CIM configuration, but what I have to put user in the settings in the server administrator CIM?
What user should I put the root of ESXi?
Thanks again

0
 
LVL 4

Author Closing Comment

by:k3pa
ID: 35083636
I finally used vsphere cli. This solved the problem.
0

Featured Post

Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

Join & Write a Comment

HOW TO: Install and Configure VMware vSphere Hypervisor 6.5 (ESXi 6.5), Step by Step Tutorial with screenshots. From Download, Checking Media, to Completed Installation.
In this article, I will show you HOW TO: Suppress Configuration Issues and Warnings Alert displayed in Summary status for ESXi 6.5 after enabling SSH or ESXi Shell.
Teach the user how to use create log bundles for vCenter Server or ESXi hosts Open vSphere Web Client: Generate vCenter Server and ESXi host log bundle:  Open vCenter Server Appliance Web Management interface and generate log bundle: Open vCenter Se…
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now