Link to home
Start Free TrialLog in
Avatar of hopmedic
hopmedicFlag for United States of America

asked on

SQL Server 2008R2 Connection Problem

I have a Windows 2008R2 Server in my home, and have installed SQL Server 2008R2 on it.  I am having connection problems, both locally and on the server, connecting to this SQL Server instance.

Scenario 1 - Was getting error 233 when attempting to connect using SSMS on the server (localhost).  I thought I had this problem solved last night, after finding suggestions to disable shared memory protocol, as well as named pipes.  I went through several trial and error attempts, and after finding a suggestion to connect to the master db instead of <default>, it worked.  After that, connecting to <default> worked.  I then turned Named Pipes and Shared Memory back on, and it still worked.  

Scenario 2 - Now that I got it connected locally, I went to my laptop.  After much frustration, I found that Windows Firewall was blocking me, and I put the exception in, and was able to connect with SSMS using the remote client.  Good.

This morning, on the laptop, I connected using SSMS, no problem.  Then I started to do an import from a flat file.  When I got to Finish, I clicked it, and I got a login error (don't remember what error it was now, but it suggested too many connections, server too busy - you know - the ever-so-helpful Microsoft errors).  I disconnected from the server in SSMS, and now I cannot connect again.  Nothing has changed on the server.  I get the 10054 error, with the statement  that a connection was established, but there was a problem during the login process, and that the connection was forcibly closed.

I went back to the server, logged in, and using SSMS on localhost, I end up getting the 233 error.  I turned off shared memory, and connected to master instead of <default>, and that worked.  Then I connected to <default> and that worked.  I turned shared memory back on, and it still worked.  But the remote SSMS from the laptop still won't connect.

Also, TCP/IP and Named Pipes are both turned on, and remote connections are allowed.  I'm puzzled at the inconsistency of this problem.  Any suggestions?
Avatar of hopmedic
hopmedic
Flag of United States of America image

ASKER

Ugh... Now it's giving me the 10054 error when I try to connect from the server (localhost)...
Grrr... I got it to working again, by disabling shared memory and named pipes.  I'd still like to know why it doesn't work with them enabled.  I don't recall reading anywhere that only one protocol is allowed...  :/
Ok - I stepped away from the laptop, and then came back to import the flat file, and I got a prelogin error.  Now I can't connect at all from the laptop.  I went back to the server, and from localhost, I got the 10054 error.  Instead of localhost, I tried (local), and I got a 10053 error (that's a new one for me).  I restart the sql server service, and we're good again.  So since with each change I made before, I had to restart the service, I'm wondering now if restarting the service is what is solving the issue for the moment, and not the changes I've made.  Assuming for the moment that is the case, what is making my sql server service fall asleep?
ASKER CERTIFIED SOLUTION
Avatar of hopmedic
hopmedic
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of Vitor Montalvão
hopmedic, what's the SQL Server version and edition?
Because no other solution was offered, and the problem was resolved.