Solved

Cannot see LUN's on SAN

Posted on 2011-02-11
14
4,197 Views
Last Modified: 2012-05-11
Hi guys,

Here is my environment :

SAN HP EVA 4100

To be upgraded :

HP DL380 G5  Vmware ESX 3.5    x  4
Vcenter 2.5


New Equipments :  
HP DL380 G5 with Vsphere 4.1  <- this guys cannot see LUNs
Vcenter 4.1

I am working on upgrade vmware to 4.1 but i want to add new host before starting upgrade so i installed new Vcenter 4.1 and installed new host with vsphere 4.1
Added new host on new vcenter but I cannot see LUNS which is very weird situation here .

Running HOST are seing luns is prod . but we tried all week to make new server see lun but didnt worked.

what i tried :

-Changed 4 HBA FC  ( to eliminate broken HBA idea )
-Vsphere 4.1 on HP DL380 G7   ( to eliminate old server idea )
-then downgraded G5 to ESX 3.5            ( to eliminate Vmware verison possiblity)
-HBA lights mean : drivers loaded link is up
-Fiber switch sees the HBA
- Checked storage side and the host is configured as all others... seems ok

Any Suggestion


0
Comment
Question by:JeanPoL
  • 6
  • 6
  • 2
14 Comments
 
LVL 23

Expert Comment

by:jakethecatuk
ID: 34871918
have you configure the fibre switch so that the new server 's WWN has access to the LUN you want it to use?
0
 
LVL 119
ID: 34872112
Have you also presented the LUNs on the SAN to the new WWNNs? (and ensured the Connection Profile is Linux if applicable)
0
 
LVL 3

Author Comment

by:JeanPoL
ID: 34872275
@ jakethecatuk : yeah we configured the fiber switch ,add WWN of Servers HBA.

@hanccocka : Also we did this.

Interesting issue on EVA ,  on configurations we did before WWN was appearing on host selection list automatically but this time didnt appear but we wrote it manually.

0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 
LVL 23

Expert Comment

by:jakethecatuk
ID: 34872309
if the EVA isn't seein the WWN automatically then that could be part of your problem as the fibre subsystem generally automatically sees new cards when they are connected correctly.

Obvious thing to checks (but sometimes the obvious eludes us) - different fibre cable and making sure that Tx and Rx are the same at both ends
0
 
LVL 119
ID: 34872436
We had an issue this week, with FC cards and hbas with our SAN HP EVA 4100.

1. new fc hba card installed in server - tick
2. WWNNs added to switch - tick
3. WWNNs added to LUNs - tick
4. hba lights on card and switch - tick
5. hba visible in ESXi 4.1. - tick
6. but no LUNs visible
7. no connection in the SAN (viewed from SAN)
8. Checking FC BIOS tools, it could see LUNs, but ESXi 4.1 couldn't!
9. Checked ESXi logs, card found, initialized but didn't return any LUNs.

baffled, changed the card, same thing.

changed the slot on Server - it worked!
0
 
LVL 3

Author Comment

by:JeanPoL
ID: 34873520
I changed fibre cable also but i'll change it again.

Actually i have installed two HBA to prevent single point of failure. One HBA goes to FiberSwitch 1 and another HBA is connected FiberSwitch2 none of them is working.i see them on ESX ( model is Emulex Lpe1150 ).
There is EVA4100 and EVA4400. It must see the both storages. ( i didnt metioned this in order to keep topology simple)

Also there is BIOS of HBA but i dont know what to do there , i reseted them to deafault settings.

How can i check from FC BIOS tools btw ?
0
 
LVL 119
ID: 34873586
Normally, there is an option like CTRL-R, CTRL-A which allows you to use the HBA Bios tools?
0
 
LVL 3

Author Comment

by:JeanPoL
ID: 34887187
I get in to bios tools but dont know what to do or how to check SAN connectivity ?

I put two printscreen maybe you can guide me ?
Emulex-Lpe1150-BIOS-settings-1.JPG
Emulex-Lpe1150-BIOS-Adapter-para.JPG
0
 
LVL 119
ID: 34887297
if you select Configure devices, do you see any LUNs?
0
 
LVL 3

Author Comment

by:JeanPoL
ID: 34887394
i checked . I have two HBA adapters which is connected two different fiber switch.


Adapter-1.JPG
Adapter-2.JPG
0
 
LVL 3

Author Comment

by:JeanPoL
ID: 34887705
difference on these are that i changed topology of 2nd adapter to FC-AL.
but still nothing .

when i do esxcfg-mpath -a

i see my two HBA's.

when i do esxcfg-mpath -l

i see only one path which belongs to local drive.
0
 
LVL 119
ID: 34888216
select 1?
0
 
LVL 3

Author Comment

by:JeanPoL
ID: 34888602
i did it and black screen stays like touch any key and nothing happens.

I forwarded issue to Storage team , even i checked their config on SAN i am forcing them to do it again.

What is your thought , is the problem on Storage side or  Machine/ Vmware thing ?
0
 
LVL 119

Accepted Solution

by:
Andrew Hancock (VMware vExpert / EE MVE^2) earned 500 total points
ID: 34888677
Storage not presented correctly. e.g. on SAN or Zoning on the switches.

if the LUNs are presented correctly the BIOS should see something like this....

first picture is the FC hba connected to the MSA 1000...

 FC hba connected to MSA1000
then if you select that number, you can see the LUNs as follows

 LUNs presented to hba on MSA1000
There's not really much config to do on ESX connecting to FC LUNs, other than install supported hba card, make sure zoning is corrrect for WWNNs on both switches, make sure WWNNs are presented correctly, and LUN HCLs are correct on SAN - and connect ESX server, LUNs should come up, with VMFS, if they are already formatted as VMFS.

and they should automatically come up without a rescan.

The only other way to prove this would be to install and OS, that supports HBAAnywhere e.g. WIn2k3, WIn2k8 etc on the server, and check with that, if it see's LUNs.

But it should see LUNs from the BIOS.

Get on the Management Switches and check for valid flogi and plogi connections.
0

Featured Post

Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
cannot rename datastore 3 71
VCAP6-DCV Exam 11 112
vCenter Server Health Check Alarm 3 47
VMware SRM - Datastore not showing in Array Replication 11 74
When converting a physical machine to a virtual machine using VMware vCenter Converter Standalone or vCenter Converter Enterprise, if an adapter type is not selected during the initial customization the resulting virtual machine may contain an IDE d…
In this article, I will show you HOW TO: Install VMware Tools for Windows on a VMware Windows virtual machine on a VMware vSphere Hypervisor 6.5 (ESXi 6.5) Host Server, using the VMware Host Client. The virtual machine has Windows Server 2016 instal…
Teach the user how to rename, unmount, delete and upgrade VMFS datastores. Open vSphere Web Client: Rename VMFS and NFS datastores: Upgrade VMFS-3 volume to VMFS-5: Unmount VMFS datastore: Delete a VMFS datastore:
Teach the user how to convert virtaul disk file formats and how to rename virtual machine files on datastores. Open vSphere Web Client: Review VM disk settings: Migrate VM to new datastore with a thick provisioned (lazy zeroed) disk format: Rename a…

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question