Link to home
Start Free TrialLog in
Avatar of yballan
yballanFlag for United States of America

asked on

Importing data into FileMaker from Excel

Hi, I am converting Access database into FileMaker.  I have exported all of the data from Access into Excel, have gone through the import process, but am still having issues.
In Import Records -> File... command, after I choose my Excel workbook, I cannot use "Match records based on this field", because it is grayed out.
Also, when I try to just simply add new records, it gives me the same amount of blank records, which I have to delete afterwards.  I feel like I am not using the Imort function properly, although I am following the tutorial steps.
Please advise.
Avatar of Will Loving
Will Loving
Flag of United States of America image

I think what you are wanting to do is an Import that creates a table at the same time. To do this, click Import and select your file and worksheet. One you are in the field matching screen, click the "Target" pop-up menu above the right-hand column and select "New Table...".

Then in the Lower Right corner of the Import Field Matching, click "Don't import first record (contains field names)". This will cause FileMaker to create a new table with the fields named the same as the first row in your spreadsheet. If your first row is data rather than field names, consider changing the spreadsheet before you import it to have the first row have field names. It's much faster to do it that way then to change them after FileMaker names them all f1, f2, f3, etc.

Once table is created and all records imported, you can change the name of the table - which defaults to your spreadsheet name - to something more appropriate. If you are importing multiple tables, do the procedure above with each one and then build the relationships between the tables as required to match your Access database.
Avatar of yballan

ASKER

Dear willmcn,
Thank you for your reply.  I am actually trying to add new data to existing table.
I followed your instructions, but that creates a new table with new info only.
I want to be able to augment my existing table, and also be able to update the existing table with new data after matching the records based on my ID field.
If you are wanting to import using "Matching Fields" then you need to make sure that column headings in your spreadsheet match the fields in FileMaker. You can either change them in FileMaker or in your spreadsheet (or even in Access). if the field names don't match exactly you have to line them up manually, which it's easy to make mistakes doing if you have a lot of fields (speaking from experience!).

In your original post you said:  

I cannot use "Match records based on this field", because it is grayed out.

I think what is missing is that you have neglected to check the box in the lower left corner of the Import Field Mapping dialog that says:  "Don't import first record (contains field names)". Clicking this checkbox should allow you to set the Arrange by setting to "Matching"
Avatar of yballan

ASKER

Hi, willmcn,

I do have the "Don;t import fiest record" checked.  
I just realized that if I check "Update matching records in found set", it will let me choose "Match records based on this field.
Does this mean that everytime I want to update the database by importing .xls file, I must first perform a find?
ASKER CERTIFIED SOLUTION
Avatar of savoieadam
savoieadam
Flag of Canada image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of yballan

ASKER

Yes, thank you, this is what I needed to do!