• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 602
  • Last Modified:

VMware Esxi 4 virtual machine cannot communicate outside of host

I have an IBM x3650 server running EXSI 4 and 4 virtual servers all running Windows 2008.  3 of the servers communicate perfectly with the Internet, host, other servers on the host and other devices on the LAN.  LAN is a single subnet /24.  One server can only communicate the host and servers on the host.  Tried changing static IP, adding second virtual network card, deleting all network cards and re-adding single card.  Tried both E1000 and  VMNET 3.  Then I added a new virtual machine with Windows 2008.  The new machine now could not communicate outside of the host but the original machine that couldn't now can!!  Stranger than fiction.  Does anyone have a clue or suggestion?  Thanks Milt
0
friedman_fcs
Asked:
friedman_fcs
2 Solutions
 
MarinertekCommented:
A few things to check:

1. What is the layout of your vswitches?
2. What type of security do you have on the vswitch port groups?
3. Do you have port security enabled on your physical switches?
4. VMTools is installed and fully up to date on all virtual machines
0
 
bgoeringCommented:
Some switches (Cisco ESW540 for example) have a setting where you can limit the max number of mac addresses that it will recognize. This would be an example of the "port security" in #3 above.

There are sometimes default limits even if you don't specifically set one.

What kind of physical switch are you connecting to?
0
 
friedman_fcsAuthor Commented:
Thanks I will check the vswitch and Cisco physical switch.
0
 
martginCommented:
Make sure the ethernet is connected in the vm config.
Make sure your vm are tied to a vswitch
Make sure your vswitch is tied to 1 or more external ports.

You can do all this from the vi client.

Also check your vlan config.
Might want to set the port on the cisco switch to:
switchport mode access (if not using vlans) or switchport mode trunk (if using vlan)
If using trunk port with multiple vlans, make sure you allow the vlans in question.
Make sure your port security does not have any mac filters.

But considering the changing symptoms, it might be a good idea to update the Broadcom firmware and the Broadcom drivers

Here is the general link to firmware for
http://www.ibm.com/support/fixcentral/systemx/groupView?query.productGroup=ibm%2FSystemx

Link for Vmware drivers
http://downloads.vmware.com/d/info/datacenter_downloads/vmware_vsphere_hypervisor_esxi/4_0#drivers_tools
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now