Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

.Net 2.0 and Windows 7

Posted on 2011-02-11
11
687 Views
Last Modified: 2012-05-11
I am having an issue installing an app that requires .Net 2.0 on a Windows 7 laptop. I know that .Net 3.5 is part of the os in Win 7 but my app won't install because it looks for .Net 2.0. I have tried installing .Net 2.0 but the os returns "This product is already installed as part of the operating system". I also have tried unchecking Microsoft .Net Framework 3.5.1 in the Windows Features section. I have also tried running .Net Framework Cleanup Tool with no luck.
Any help would be greatly appreciated.
0
Comment
Question by:jb25
  • 4
  • 3
  • 2
  • +1
11 Comments
 
LVL 3

Expert Comment

by:dn0rm
ID: 34873619
older versions of .net should be included with the later versions as i understand it...do you need the framework to be installed on top of something like IIS?

.net framework 2.0 should be apart of 3.5.1.

you can see if you have 2.0 components by navigating to:

C:\Windows\Microsoft.NET\Framework\v2.0.50727

your 2.0 version might be slightly different than mine...but perhaps you need to install 2.0 on top of IIS or something?

0
 

Author Comment

by:jb25
ID: 34873672
You are correct. .Net 2.0 is installed with 3.5. The problem is that the app doesn't see it when it is installing and terminates the install with a window that states "You need .Net 2.0 to install this application". So what i'm trying to do is uninstall any .Net Famework that is installed as part of the Win 7 os and then install  .Net 2.0 so that the app sees it during its install.
0
 
LVL 3

Expert Comment

by:dn0rm
ID: 34873800
man...MS hasn't made it easy for us have they?  ;)

well it sounds like you may be on the correct path...best of luck to you and let us know if we can do anything to help!

thanks!
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 
LVL 33

Expert Comment

by:Todd Gerbert
ID: 34874189
How are you packaging your application?
0
 

Author Comment

by:jb25
ID: 34874408
I'm not sure what you mean. The application is installed by a Windows Installer Package.
0
 
LVL 4

Expert Comment

by:dailypcguy
ID: 34874754
Have you tried running the app in XP compatibility mode?
Alternatively because it sounds like a legacy app designed to run in a pre-win7 environment you could install the applications to run a virtual copy of XP on your machine, and install the app in that virtual XP - provided you have either professional or ultimate win 7 installed.

http://www.microsoft.com/windows/windows-7/features/windows-xp-mode.aspx
0
 
LVL 33

Expert Comment

by:Todd Gerbert
ID: 34874856
Oops...I was assuming it was an application you wrote and packaged yourself.  Is that the case, or are you just installing something you purchased/downloaded?
0
 

Author Comment

by:jb25
ID: 34874863
Its a program we purchased.
0
 
LVL 33

Accepted Solution

by:
Todd Gerbert earned 500 total points
ID: 34902657
Hmm, if I build an appication based on .Net 2.0, and make a .MSI for it that checks for .Net 2.0, it installs okay for me on a clean out-of-the-box installation of Windows 7.

I'm not sure why it would think you don't have .Net 2.0 - the logic the setup program is using to determine whether or not .Net 2 is installed must be wrong.

Your best bet will be to go back to the program's author and see if they have an update.

Alternatively, you might be able to use something like Sysinternal's Process Explorer (http://www.sysinternals.com/) to see what files or registry keys the setup program's trying to find, and create dummies to trick it into thinking .Net 2 is installed.

Or, try something like Universal Extractor (http://legroom.net/software/uniextract) to get the files out of the .MSI and install them manually.
0
 

Author Comment

by:jb25
ID: 34906439
Thanks, I will try both ideas.
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Copying from excel I am getting extra text 11 48
Outlook 2016 Huge Memory Leak 9 62
Toshiba e456 color copier driver download 3 28
Connection reset by peer 18 30
Article by: Lee
Windows 7 Ultimate and Enterprise (and 2008 R2) introduced a new feature you may not be aware of - Boot from VHD.   Boot from VHD (or what Microsoft refers to asNative Boot allows you to install Windows to a VHD (Virtual Hard Disk) file that is t…
A quick guide on how to use Group Policy to create a custom power plan and set it active on Windows 7.
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
This Micro Tutorial will go in depth within Systems and Security in Windows 7 and will go into detail regarding Action Center, Windows Firewall, System, etc. This will be demonstrated using Windows 7 operating system.

808 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question