Can't connect 2008 SVR VM to internet (vmware)

i have a 2008 server vm, Network configuration is set to NAT. it won't connect to anything on the internet. can't ping www.yahoo.com or resolve Google in IE.

HOST os is connected to internet fine. host firewall has been disabled for testing, guest VM firewall is disabled also.


thanks,
ob1
LVL 6
ob1_Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
dailypcguyConnect With a Mentor Commented:
I also notice you have no default gateway listed in your print out. Have you tried to flush the DNS and renew it to see if it identifies a default gateway. Otheraise you might have to enter it manually and see if that does the trick
0
 
bgoeringCommented:
On your guest make sure the boxes for connected (when its powered up) and connect at power on are checked. What are you running? Workstation 7?
0
 
bgoeringCommented:
Also see if it is pulling an IP address, post back the output from a cmd session

ipconfig /all
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
ob1_Author Commented:
yes workstation 7. yes i get a 192.168.253.x address. the 2 boxes for connected are checked. is it possibly a SVR 2008 security setting?



Windows IP Configuration

   Host Name . . . . . . . . . . . . : WIN-C7KKGAIM74Y
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : localdomain

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : localdomain
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection
   Physical Address. . . . . . . . . : 00-0C-29-1C-7B-D3
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::7193:30b8:a7:f1c5%10(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.253.130(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Friday, February 11, 2011 10:28:41 AM
   Lease Expires . . . . . . . . . . : Friday, February 11, 2011 3:28:41 PM
   Default Gateway . . . . . . . . . :
   DHCP Server . . . . . . . . . . . : 192.168.253.254
   DHCPv6 IAID . . . . . . . . . . . : 234884137
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-E7-31-A2-00-0C-29-1C-7B-D3
   DNS Servers . . . . . . . . . . . : 192.168.253.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter Local Area Connection* 8:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : localdomain
   Description . . . . . . . . . . . : isatap.localdomain
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
0
 
dailypcguyCommented:
I think there is a setting to make the connection private (public connections not good) in your VMware config box before your power on your VM. I have SBS 2011 installed in VM and it connects to internet fine (no AV running in the VM). I just get a desktop with no task bar or start menu which might be default for security, I'm not yet sure.
Strangely enough I tried changing this connection type to Bridged or Host Only and couldn't get connected to the net either way. NAT worked fine at least on my XP VM
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Administrator>ipconfig /all

Windows IP Configuration

        Host Name . . . . . . . . . . . . : david-706c247f8
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Hybrid
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No
        DNS Suffix Search List. . . . . . : localdomain

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . : localdomain
        Description . . . . . . . . . . . : VMware Accelerated AMD PCNet Adapter

        Physical Address. . . . . . . . . : 00-0C-29-B9-87-17
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 192.168.132.128
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.132.2
        DHCP Server . . . . . . . . . . . : 192.168.132.254
        DNS Servers . . . . . . . . . . . : 192.168.132.2
        Primary WINS Server . . . . . . . : 192.168.132.2
        Lease Obtained. . . . . . . . . . : Saturday, February 12, 2011 8:47:23
AM
        Lease Expires . . . . . . . . . . : Saturday, February 12, 2011 9:17:23
AM

but with Direct Connection I got this result

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Administrator>ipconfig /all

Windows IP Configuration

        Host Name . . . . . . . . . . . . : david-706c247f8
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Unknown
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No
        DNS Suffix Search List. . . . . . : localdomain

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . : localdomain
        Description . . . . . . . . . . . : VMware Accelerated AMD PCNet Adapter

        Physical Address. . . . . . . . . : 00-0C-29-B9-87-17
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 192.168.223.128
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . :
        DHCP Server . . . . . . . . . . . : 192.168.223.254
        DNS Servers . . . . . . . . . . . : 192.168.223.1
        Lease Obtained. . . . . . . . . . : Saturday, February 12, 2011 7:44:11
AM
        Lease Expires . . . . . . . . . . : Saturday, February 12, 2011 8:14:11
AM

I'd be checking the firewall rules in the server and making sure that port 80 isn't blocked by default. As I mentioned I have a SBS 2008/2001 installation on another machine in VMware, and it seems to update from the internet just fine.
0
 
bgoeringConnect With a Mentor Commented:
Your default gateway is missing in your IP configuration. I believe on NAT that should be set to the ".2" address on your NAT segment. Try manually configuring IP as follows:

IP Address: 192.168.253.130
Subnet mask: 255.255.255.0
Default Gateway: 192.168.253.2
DNS Server: 192.168.253.2

Let me know what happens - if this fixes it we need to look at the NAT configuration.
0
 
ob1_Author Commented:
thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.