Solved

Intergrating Asterisk Voicemail and CME 4.1

Posted on 2011-02-11
12
2,891 Views
Last Modified: 2013-12-27
Intergrating Asterisk Voicemail and CME 4.1

Question: CME 4.1 Running on a Cisco 2651XM:    SIP Truck from ISP providing incoming & going calls and DIDs

R1#sh run
Building configuration...

 !
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R1
!
boot-start-marker
boot-end-marker
!
 !
aaa new-model
!
!
--More--

aaa session-id common
clock timezone Pacific -8
clock summer-time pacific recurring
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.8.1 192.168.8.15
!
ip dhcp pool VOIP
  network 10.1.8.0 255.255.255.0
  option 150 ip 10.1.8.1
  default-router 10.1.8.1
  lease 7
!
ip dhcp pool DATA
  network 192.168.8.0 255.255.255.0
  option 150 ip 192.168.8.1
  default-router 192.168.8.1
  dns-server 69.44.00.00
  lease 7

no ip domain lookup
 
ip name-server 69.44.XX.XX
ip name-server 69.44.XX.XX
ip name-server 8.8.8.8
!
multilink bundle-name authenticated
!
!
voice service voip
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
fax protocol pass-through g711ulaw
sip
 bind control source-interface FastEthernet0/1
 bind media source-interface FastEthernet0/1
 registrar server expires max 3600 min 3600
 no call service stop
!
!
voice class codec 1
codec preference 1 g711ulaw
!

!
voice translation-rule 1
rule 1 /714700000/ /201/
!
 
voice translation-profile IncomingCalls
translate called 1


!
username user privilege 15 password 0 000
username admin privilege 15 password 0 000
archive
log config
 hidekeys
!

interface Loopback0
ip address 10.1.9.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
ip nat inside
ip virtual-reassembly
speed 100
full-duplex
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 10.1.8.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/0.3
encapsulation dot1Q 3 native
ip address 192.168.8.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/1
description External WAN Connection
ip address 38.96.00.00 255.255.255.248
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 38.96.00.00

!
ip http server
no ip http secure-server
ip nat pool WANPOOL 38.96.00.00 38.96.00.00 prefix-length 29
ip nat inside source list 10 pool WANPOOL overload
!
access-list 10 permit 192.168.8.0 0.0.0.255
access-list 10 permit 10.1.8.0 0.0.0.2

tftp-server flash:P00308010200.bin
tftp-server flash:P00308010200.loads
tftp-server flash:P00308010200.sb2
tftp-server flash:P00308010200.sbn
tftp-server flash:music-on-hold.au
!
control-plane
!

!
dial-peer voice 201 voip
description *** SIP-TRUNK (OUT) ***
destination-pattern 9..
voice-class codec 1
session protocol sipv2
session target dns:abc.net
dtmf-relay sip-notify rtp-nte
!
dial-peer voice 210 voip      :: Dial Peer to the asterisk box.      
description Voice mail dial peer
destination-pattern 22...
session protocol sipv2
session target ipv4:192.168.xx3.254
dtmf-relay rtp-nte
codec g711ulaw
no vad

!
sip-ua
credentials username XXX password XX realm asterisk
authentication username XX password 7 XX realm asterisk
retry invite 2
retry register 3
timers connect 100
registrar dns:XX.net expires 3600
registrar dns:XX.net expires 3600 secondary
sip-server dns:XX.net
 host-registrar


telephony-service
load 7960-7940 P00308010200
max-ephones 35
max-dn 35
ip source-address 10.1.9.1 port 2000
timeouts interdigit 4
system message XX
max-conferences 4 gain -6
call-forward pattern .T
call-forward system redirecting-expanded
moh music-on-hold.au
transfer-system full-consult dss
transfer-pattern .T
secondary-dialtone 9
directory last-name-first
voicemail 3999      :: Voicemail extension
mwi ipv4:192.168.8.231 unsolicited  :: Music on hold from Asterisk box
create cnf-files version-stamp 7960 Jan 15 2011 20:22:06
!
!
ephone-template  5
softkeys idle  Newcall Cfwdall Pickup
softkeys seized  Endcall Cfwdall Pickup
softkeys alerting  Endcall
softkeys connected  Endcall Hold Park Trnsfer Confrn
softkeys ringing  Answer
type 7960
!
!
ephone-dn  1
number 231
label Ext 231
description 714-700-0000
name Etx 231
call-forward busy 3231
call-forward noan 3231 timeout 10

ephone  1
device-security-mode none
mac-address A8B1.D41E.DC31
ephone-template 5
type 7960
button  1:1

The phone was power cycled to get the new settings.
All phones can place and receive call, can transfer etx. I’m trying to integrate Asterisk voicemail with Cme 4.1


--- Asterisk 1.8 FreePBX Config

Using Webmin-Filemanager-Edit, I added the following lines to /etc/asterisk/extensions_custom.conf

Number that CME dial to access voice mail when the message button is depressed on the IP Phone.
exten => 3999,1,VoicemailMain(${CALLERIDNUM})
exten => 3999,2,Wait(3)
exten => 3999,3,Hangup

;Number that CME dials to forward voice mail to Asterisk
exten => _3XXX,1,Setvar(ext=${EXTEN:1})
exten => _3XXX,2,Goto,vmail|s|1



Using FreePBX, I created a SIP trunk to CME’s Voice VLAN.

Trunk Name: DestoCME

Peers Detials
Host = 192.168.8.1
Type = friend
Qualify = yes
Context = cme-trunk



Using Free PBX, I created an outbound route to the CME trunk created previously:

Add Route:

Route Name: CME
Dial Patterns: 32XX

Truck Sequence: SIP/cme -trunk

Everything else defaults


For the CME voicemail extension, I created a corresponding SIP extension in Asterisk PBX with no secret

(Extension password), a DID number, enable voicemail services and check the NAT settings:

Add Sip Extension

User Extension: 3231
Display/ Name: CME3231

Add a DID entry with a prefix of 3 and leave the secret blank (no password):

Did Description: CME3231
Add Inbound DID: 3231

I enabled voicemail

And set Nat = no

My Problem:

When I press the voicemail button on the Cisco 7960 or dial the voicemail extension 3231 it display “Host cannot be found” on the phone
There seems to be no connection between the cme and asterisk
My question do I need a second sip-ua connecting the Cisco CME to asterisk?

Any ideas will help

Thanks again.
0
Comment
Question by:MikeLeePIT
  • 6
  • 6
12 Comments
 
LVL 15

Expert Comment

by:deepdraw
ID: 34874893
I dont know that you can have two sip-ua on cme.
Have you tried putting an acl to the asterisk box and setting up logging to see if there is any traffic
The easy way is to set up sip to receive calls on the asterisk box, then get that to handle the calls.
then set cme to just register with the asterisk box.


Greg
0
 

Author Comment

by:MikeLeePIT
ID: 34885484
Ok. I got CME to place calls to the asterisk box. I can leave and retrieve voice mail from the asterisk server.

I'm having problems with the auto-attendant.

When a call comes in on off the main sip-ua for the 800 number its directed to extension 4000. from there it should go through the asterisk dial peer 210 and hit the asterisk box. From there a ivr will be played and based on which option the client selects the call should be rerouted back to the cme phone extension to be answered.  

I''m using nat on the main internet facing interface. Do I need to configure a ip nat source static mapping the outside public ip to the router internal  ip for port 5060?

Thanks again.

0
 
LVL 15

Expert Comment

by:deepdraw
ID: 34886072
I would suggest that the asterisk box registers with the sip provider.
This is a more simple solution.
Also i dont think you can have two sip user agents on one router.

Greg
0
 

Author Comment

by:MikeLeePIT
ID: 34888012
Your saying to make it easier move the sip truck to the asterisk box. All incoming/ outgoing calls will go through the asterisk server instead and be forwarded back to the cme through a sip-ua connecting the cme and asterisk box together.

How would I make a sip-ua between the cme and asterisk. Don't this require the asterisk box to be a sip proxy?

Thanks again.

0
 
LVL 15

Expert Comment

by:deepdraw
ID: 34888953
yes  All incoming/ outgoing calls will go through the asterisk server
cme and asterisk is easy. there is lots of help on the web.

Don't this require the asterisk box to be a sip proxy? No
link to cme and asterisk.

http://fonality.com/trixbox/forums/trixbox-forums/trunks/multi-fxo-ip-ata?page=1

Greg
0
 

Author Comment

by:MikeLeePIT
ID: 34900302
I know you told me to use asterisk instead for the sip registration and create a sip-ua between the cme and asterisk.

I have to use asterisk to host there voice mailboxs. So in the case of a system failure there numbers and 800number can be forward to the asterisk box instead for voice mail etc. But due to bandwidth and phone type "sscp" the voip phones are connected to a local cme router.

I was going to have the isp separate the main 800 number to a new sip register and configure the main 800 number to ring the asterisk box. Once the client selects the option/extension the call should be routed back to the cme to be answered on a local extension.

I have a outgoing truck and outgoing routes to the cme from asterisk. When I try to ring one of the cme etx I receive a "all circuits is busy message" from asterisk.

Outgoing from cme to asterisk rights fine. Asterisk pick up the extension and routes it to voice mail.. this is the dial peer I'm using in cme.

dial-peer voice 210 voip
 description VoiceMail AutoAtten dial peer
 destination-pattern 3...
 session protocol sipv2
 session target ipv4:173.231.00.00 <--- Public ip of asterisk nox
 session transport udp
 dtmf-relay rtp-nte
 codec g711ulaw

I'm having issues with incoming calls from asterisk to cme. Standard nat on internet facing interface.
This is the dial peer that handles incoming calls from asterisk.

dial-peer voice 211 voip
 description *** Asterisk-SIP-TRUNK (IN) ***
 translation-profile incoming IncomingCalls
  dtmf-relay rtp-nte
 codec g711ulaw
 session protocol sipv2
 session target ipv4:173.231.00.00  <--- Public ip of asterisk box
 incoming called-number .%
 no vad

####Asterisk configuration:

This is the trunk config from asterisk for outgoing to cme.


Trunk Name: 17th_Street

host=38.96.00.00  <--- Public of cme
disallow=all
allow=ulaw
type=peer
dtmf=rfc2833
nat=yes
insecure=very
canreinvite=yes
context=from-internal
qualify=yes

My outbound routes:

Dial Patterns   2XX   <--- My extension range on cme is 233 - 258

Trunk Sequence: sip/17th_Street


Thanks again
0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 15

Expert Comment

by:deepdraw
ID: 34901498
This looks to be the holy grail of cme and asterisk trunks :)
http://www.voip-info.org/wiki/view/Asterisk+Cisco+CallManager+Integration

It is important to use "qualify" in sip.conf since Call Manager does not support registration for SIP trunks.
My mistake. I thought you had to have a sip-ua on this.

also worth a look.
https://learningnetwork.cisco.com/docs/DOC-3161

Greg
0
 

Author Comment

by:MikeLeePIT
ID: 34907025
Hi

I followed those two articles. The first one is using the gui to configure the dial peers for calling to asterisk. I got that portion working.

I'm still having issues with incoming calls from asterisk into the cme. I'm using freepbx and when I ssh into extension.conf it said do not edit this file directly. It have a dial peer from the isp and it works fine for incoming. But I don't know what conflagration I need on the asterisk said to push calls to cme.



0
 

Author Comment

by:MikeLeePIT
ID: 34907915
This is the dial peer I'm using for outgoing call to asterisk and it works.

dial-peer voice 210 voip  
 description Voice mail dial peer
 destination-pattern 3...
 session protocol sipv2
 session target ipv4:173.231.00.00   <--IP of asterisk box
 session transport udp
 dtmf-relay rtp-nte
 codec g711ulaw


The problem is with this dial peer. This is incoming calls from asterisk to cme.

dial-peer voice 211 voip
 description *** Asterisk-SIP-TRUNK (IN) ***
 translation-profile incoming IncomingCalls
 session protocol sipv2
 session target ipv4:173.231.00.00  <--IP of asterisk box
 incoming called-number 2..  <-- my extension are in the 200 range.
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad

Will nat block this from working?
0
 
LVL 15

Expert Comment

by:deepdraw
ID: 34910374
Can you show topology so i can see the nat.
I dont think there is an issue if you edit the files in trixbox directly.
0
 

Author Comment

by:MikeLeePIT
ID: 34910885
The router the cme is running on is performing the nat. There is no firewall in front of the cme. What I cant get my mind around is the fact that my isp dial peer works with no problem but the asterisk dial is not working.

Will the dial peer allow traffic coming from my asterisk box on port 5060 to transverse my nat?

So this is what I have so far.


My CME config.

R1>en
Password:
R1#sh run
Building configuration...

Current configuration : 13472 bytes
!
! Last configuration change at 22:15:46 Pacific Mon Feb 14 2011 by mdyer
! NVRAM config last updated at 20:49:27 Pacific Mon Feb 14 2011 by mdyer
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
logging buffered 4096
enable secret 5 $1$XvCD$2Hm2wLmAFOizex4Xv0uPb.
!
aaa new-model
!
!
!
!
aaa session-id common
clock timezone Pacific -8
clock summer-time pacific recurring
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.8.1 192.168.8.15
ip dhcp excluded-address 192.168.8.10
ip dhcp excluded-address 192.168.8.231
!
ip dhcp pool VOIP
  network 10.1.8.0 255.255.255.0
  option 150 ip 10.1.8.1
  default-router 10.1.8.1
  lease 7
!
ip dhcp pool DATA
  network 192.168.8.0 255.255.255.0
  default-router 192.168.8.1
  dns-server 00.00
  option 66 ip 192.168.8.1
  lease 7
!
!
no ip domain lookup


!
multilink bundle-name authenticated
!
!
!
voice rtp send-recv
!
voice service pots

voice service voip
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
fax protocol pass-through g711ulaw
sip
 bind control source-interface FastEthernet0/1
 bind media source-interface FastEthernet0/1
 registrar server expires max 3600 min 3600
 no call service stop
!
!
voice class codec 1
codec preference 1 g711ulaw
!
!
!
!
!
!
!
!
!
!
!
!
voice translation-rule 3
rule 1 /^71370000/ /2/ <--Translation for 28 did to internal extenstions
rule 3 /7147630000/ /4000/ <--Main 800 number
!
!
voice translation-profile IncomingCalls
translate called 3
!
!
!
!
!
!

log config
 hidekeys
!

interface Loopback0
ip address 10.1.9.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
ip nat inside
ip virtual-reassembly
speed 100
full-duplex
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 10.1.8.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/0.3
encapsulation dot1Q 3 native
ip address 192.168.8.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/1
description External WAN Connection
ip address 38.96.00.00 255.255.255.248
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 38.96.00.00
!
!
ip http server
no ip http secure-server
ip nat pool WANPOOL 00.00 prefix-length 29
ip nat inside source list 10 pool WANPOOL overload

access-list 10 permit 192.168.8.0 0.0.0.255
access-list 10 permit 10.1.8.0 0.0.0.255
!
!
!
!
tftp-server flash:P00308010200.bin
tftp-server flash:P00308010200.loads
tftp-server flash:P00308010200.sb2
tftp-server flash:P00308010200.sbn
tftp-server flash:music-on-hold.au
!
control-plane
!
!
!
ccm-manager music-on-hold
!
!
!
!
dial-peer voice 201 voip
description *** SIP-TRUNK (OUT) ***
destination-pattern 9[0-1][2-9]..[2-9]......
voice-class codec 1
session protocol sipv2
session target dns:abc.abc
dtmf-relay sip-notify rtp-nte
!
dial-peer voice 210 voip
description Voice mail dial peer
destination-pattern 3...  <---Asterisk extenstion start at 3200
session protocol sipv2
session target ipv4:173.231.00.00
session transport udp
dtmf-relay rtp-nte
codec g711ulaw
!
dial-peer voice 211 voip
description *** Asterisk-SIP-TRUNK (IN) ***
translation-profile incoming IncomingCalls
 dtmf-relay rtp-nte
codec g711ulaw
session protocol sipv2
session target ipv4:173.231.00.00
incoming called-number 2..  <-- CME extension start at 200
no vad
!
dial-peer voice 200 voip
description *** SIP-TRUNK (IN) ***
translation-profile incoming IncomingCalls
voice-class codec 1
session protocol sipv2
session target dns:abc.abcnet
incoming called-number .%
no vad
!

sip-ua
credentials username 0000  password 0000 realm asterisk
authentication username 0000 password 7 0000 realm asterisk
retry invite 2
retry register 3
timers connect 100
mwi-server ipv4:173.231.00.00 expires 86400 port 5060 transport tcp
registrar dns:abc.net expires 3600
registrar dns:abc.net expires 3600 secondary
sip-server dns:abc.nett
 host-registrar
!
!
!
telephony-service
load 7960-7940 P00308010200
max-ephones 35
max-dn 35
ip source-address 10.1.9.1 port 2000
timeouts interdigit 4
system message
max-conferences 4 gain -6
call-forward pattern .T
call-forward system redirecting-expanded
moh flash:music-on-hold.au
multicast moh 239.1.0.0 port 16384
transfer-system full-consult dss
transfer-pattern .T
secondary-dialtone 9
directory last-name-first
create cnf-files version-stamp 7960 Feb 14 2011 11:03:00
!
!
ephone-template  5
softkeys idle  Newcall Cfwdall Pickup
softkeys seized  Endcall Cfwdall Pickup
softkeys alerting  Endcall
softkeys connected  Endcall Hold Park Trnsfer Confrn
softkeys ringing  Answer
type 7960
!

ephone-dn  1  dual-line
number 714-798-0000
label Etx 231
description 714-798-0000
name Etx 231
call-forward busy 3231
call-forward noan 3231 timeout 25
!
!

!
!
ephone-dn  35
number 4000
call-forward busy 3200
call-forward noan 3200 timeout 18
!
!
ephone  1
device-security-mode none
mac-address A8B1.D41E.DC31
ephone-template 5
type 7960
button  1:35



!
line con 0
line aux 0
line vty 0 4

transport preferred ssh
transport input ssh
!
ntp clock-period 17208406

!
end


Config on my asterisk box.

Trunk Name: 17thStreet

type=friend
qualify=yes
nat=yes
insecure=very
host=38.96.00.00 <-- IP of cme
fromdomain=38.96.00.00 <--IP of cme
dtmf=rfc2833
disallow=all
context=from-internal
canreinvite=no
allow=ulaw


USER Context  38.96.00.00 <--IP of cme

type=friend
qualify=yes
nat=yes
insecure=very
host=38.96.00.00
fromdomain=38.96.00.00
dtmf=rfc2833
disallow=all
context=from-internal
canreinvite=no
allow=ulaw

Outbound Routes

Dial Patterns: 2XX <--Extension for cme

Trunk Sequence:   SIP/17thStreet


** I don't have smd installed on the router all config is being done in ios.

When I try to dial a cme extension from a Xlite softphone connect to the asterisk box I receive an "All circuits is busing" from asterisk.

I did a show sip peers on asterisk and it display:

17thStreet                 38.96.00.00        N      5060     UNREACHABLE































0
 
LVL 15

Accepted Solution

by:
deepdraw earned 500 total points
ID: 34911343
session transport udp
would be worth adding.

Troubleshooting.

SIP

Connect to Asterisk with command 'asterisk -c'

The command 'sip debug' and 'sip debug ip' will give you access to detailled debug.

Good luck

Greg
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

How To Create Custom / Distinctive Ring Tones on Polycom Phones Purpose and Overview When creating a custom ring tone, you have simple aspirations: to make your phone cooler than everyone else's. Perhaps you need a louder ringer. Perhaps you w…
In my office we had 10 Cisco 7940G IP phones that were useless as they were showing PROTOCOL APPLICATION INVALID when started. I searched through Google and worked for a week continuously on those phones, and finally got them working. This is a di…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now