Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Can't ping WM6/WiFi in either direction

Posted on 2011-02-11
4
Medium Priority
?
646 Views
Last Modified: 2013-12-27
I have a Psion Workabout Pro3 running Windows Mobile 6.1 successfully connected to my WiFi -- I can browse the web.  I see the Workabout's IP address (192.168.1.140) from Settings->Connections->Network Cards->Network Adapters->Summit WLAN Adapter->IP Address.  But I get timeouts when I try to ping that address from my laptop on the same network.  Using TaskMgr 3.3 (dotfred.net), I try to ping my laptop (192.168.1.131) and it also times out.

Is there a firewall built into WM6, and if so, how do I configure it?
0
Comment
Question by:michaelmalak
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 16

Expert Comment

by:hjgode
ID: 34877244
Hello

there is general no firewall built into WM6.1. If a ping fails it may be caused by different sources.

Please check and send the results of the following:

a) do a ipconfig (windows) or ifconfig (unix) on the laptop
b) download and run vxUtil (http://www.cam.com/vxutil_pers.html) on the WM6.1 device: send the info produced by vxUtil on the device

Try to ping the access point from the device and the laptop, possibly it is blocking ICMP..
Try to ping an internet address from the device and the laptop.

Always use the IP address of the clients you want to ping. So we avoid using DNS,

regards

Josef
0
 

Accepted Solution

by:
michaelmalak earned 0 total points
ID: 34892195
I found the problem.  I have to have the Workabout unplugged from the USB on my laptop (and thus disconnected from ActiveSync) in order for ping to work.
0
 
LVL 16

Expert Comment

by:hjgode
ID: 34894068
Yes, if you have disabled "Allow Wireless..." in ActiveSync connection settings on PC, the device's wireless connection will be disabled if connected via ActiveSync.

You just had to change this connection settings and allow Wireless connection during ActiveSync. Otherwise you have to disconnect from ActiveSync to let the device use its wireless connection and to be able to use this wireless connection for PING.
0
 

Author Closing Comment

by:michaelmalak
ID: 34932157
Found the solution to my own problem
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

As the title indicates, I have done this before. It chills me everytime I update the OS on my phone, (http://www.experts-exchange.com/articles/18084/Upgrading-to-Android-5-0-Lollipop.html) because one time I did this and I essentially had a bricked …
You should read OS supplied guidelines before developing. I can't stress that enough. The guidelines will help you understand the reasons mobile app developers do what they do.  Apple is very particular when they review appstore submissions.
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…
Suggested Courses

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question