Solved

problems backing up C:\Users\<username>\Documents in Windows 7

Posted on 2011-02-11
5
611 Views
Last Modified: 2012-08-13
Hi,

I am using Robocopy to back up "C:\Users\<username>\Documents to I:\System Backup\<username>

where I:\ is an external USB drive.

For some reason the target directory shows up in Explorer as my Documents while in DOS it shows up as <username> which is what I would expect.

The full line in my batch file is as shown


I just don't get this. I run this command on 2K, 2003, XP and 2008 without any problems but in Windows 7 it renames my directory and changes the folder icon.

I have attached screenshots of the Exploer View and the DOS view.

can anyone shed any light on this please?
robocopy "C:\Users\Hedley\Documents" "I:\System Backup\Hedley" /MIR /Z /R:10 /LOG:Documents_backup.txt /NP /V
robocopy "C:\Users\Melanie\Documents" "I:\System Backup\Melanie" /MIR /Z /R:10 /LOG+:Documents_backup.txt /NP
robocopy G:\Music "I:\System Backup\Music" /MIR /Z /R:10 /LOG:Music_backup.txt /NP
robocopy G:\Photos "I:\System Backup\Photos" /MIR /Z /R:10 /LOG:Photo_backup.txt /NP

Open in new window

explorer-view.jpg
dos-view.jpg
0
Comment
Question by:Letterpart
  • 3
5 Comments
 
LVL 80

Assisted Solution

by:David Johnson, CD, MVP
David Johnson, CD, MVP earned 250 total points
ID: 34875167
if you logon as melanie you will see the melanie  folder will show in explorer as my documents as the desktop.ini is also being copied .. for what its worth /mir can also delete files I hope you understand this
0
 
LVL 1

Author Comment

by:Letterpart
ID: 34875273
Thanks for your reply.

I logged in as Melanie and I see exactly the same in Explorer and DOS as logged in under the other account

and yup, I know abouts /MIR. I use it at work to mirror our San arrays.

0
 
LVL 8

Accepted Solution

by:
ConUladh earned 250 total points
ID: 34875390
Delete the desktop.ini file in the Hedley/My Documents folder

If you can't see the desktop.ini file:

In any Windows Explorer window, click Tools ¿ Folder Options…
Click on the View tab.
Check off the radio button next to “Do not show hidden files and folders”.
Put a check in the box next to “Hide protected operating system files (recommended)”.
Click OK.
*******************

Going forward exlude desktop.ini when using robocopy by using the /XF switch

0
 
LVL 1

Author Comment

by:Letterpart
ID: 34875406
Sorted. Deleting the desktop.ini has fixed it.

I will /XF it from now on.
0
 
LVL 1

Author Closing Comment

by:Letterpart
ID: 34875799
Thanks guys
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
In this Micro Tutorial viewers will learn how to use Boot Corrector from Paragon Rescue Kit Free to identify and fix the boot problems of Windows 7/8/2012R2 etc. As an example is used Windows 2012R2 which lost its active partition flag (often happen…
This Micro Tutorial will teach you how to the overview of Microsoft Security Essentials. This is a free anti-virus software that guards your PC against viruses, spyware, worms, and other malicious software. This will be demonstrated using Windows…

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question