• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1099
  • Last Modified:

cannot rdp or ping new windows 2003 rras

I just installed Windows 2003 R2 with Routing and Remote Access.  This server accepts PPTP VPN connections from staff we have in the field.   We had a Win2000 server doing this for years but needed to replace the hardware and just went with W2003.   All works well but for administrative reasons we need to RDP to this server.  Neither ping nor RDP work.   I have read the MS articles on this with regard to Inbound and Outbound filters, but their KB article doesn't fit what I'm seeing in the RRAS mmc.   The server just has one NIC that is enabled.  There is a firewall that is set up to do port forwarding to forward port 1723 from the Internet so we have never used separate external and internal NICS.   Anyone know how I can get RDP (and ping) to work on this server without disrupting its successful role as our RRAS server?
0
Dgreenbaum
Asked:
Dgreenbaum
1 Solution
 
amichaellCommented:
1. The VPN successfully connects to this server, correct?
2. Is there a firewall running on the server?
3. Is Remote Desktop enabled on the server?
4. Can you RDP to the server from the LAN?
5. Can you ping the server from the LAN?
0
 
DgreenbaumAuthor Commented:
Thanks for responding
1. Yes vpn clients connect successfully
2. No the Window Firewall is not running
3. Yes RDP is enabled
4. No we can't RDP from the LAN
5. No we can't ping from the LAN

This is a known "feature" with RRAS on Win2003.  ICMP is blocked and MS has KB article 258030 about fixing it.  The issue is the article describes items on property pages that I don't see and the Inbound Outbound filter has options on it that aren't mentioned in the article.  Unfortunately most of the time I have users connected so its hard to mess with stuff.
0
 
ChiefITCommented:
When RRAS is enabled, windows firewall is also automatically enabled. You can make exceptions to ICMP echo "ping" and RDP "terminal services" in WF.

http://support.microsoft.com/kb/555381
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
DgreenbaumAuthor Commented:
I found the solution.  I uninstalled/reinstalled RRAS and, in Windows 2003 R2,  there is an option to apply "Enhanced" security on the NIC it considers to be "Outside".  When I unchecked this, it then proceeded and left me with a RRAS server that could be pinged.
0
 
ChiefITCommented:
Excellent, but don't leave yourself naked with your tunneling adapter. RRAS incorporates those security measures to hide you from port scanners to the outside world. You might want to read up on that security feature and find out what you can enable and need to disable to have some sort of security on the VPN connection. If you can't figure it out, It might be a good idea to have a hardware firewall in front of you. .
0
 
DgreenbaumAuthor Commented:
Good advice.  Yes, the RRAS server is behind a hardware firewall.  One last curiosity.   The RRAS installation wizard required me to use two NICs; in effect an Outside and Inside.  My previous server only had one NIC and was Windows 2000 and worked fine.  Will having two NICS on the same subnet present a problem?  I set the Inside NIC to not register with DNS.  Should I set up some static routes to keep things from getting confused or does RRAS 2003 take care of keeping track of routing between NICs?
0
 
DgreenbaumAuthor Commented:
I ended up finding the answer for myself, but the Experts responses helped me focus my energy
0
 
tncodeCommented:
I may have a similar problem. How do you "apply "Enhanced" security on the NIC it considers to be "Outside"  as you describe?
0
 
DgreenbaumAuthor Commented:
What I did was uninstall RRAS completely and then reinstall it.  During the installation (and because my Outside NIC is actually a private address behind a firewall) when it went through the screens as it identifies the NICs, it came up with a check for Enhanced security.  I unchecked that.  So in answer to your question, I did not apply Enhance security.  In effect, I unapplied it.
0

Featured Post

2018 Annual Membership Survey

Here at Experts Exchange, we strive to give members the best experience. Help us improve the site by taking this survey today! (Bonus: Be entered to win a great tech prize for participating!)

Tackle projects and never again get stuck behind a technical roadblock.
Join Now