Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 929
  • Last Modified:

Linux Permissions with SFTP Question

I am using CentOS 5.5 with OpenSSH 5.7 and am running into a permission issue with SFTP. I have both employees accessing the server from the internal network as well as customers accessing the server from the Internet.

All of the customers are in a group call sftpusers and are chrooted to a directory, using the internal-sftp subsystem of OpenSSH 5.7 for that group.

Inside this directory there are individual directories for each user to upload their files. The directories are setup with the customer's userid as the owner with RW permissions, and a group with RW permissions.

The customer is not in the group that has RWX permissions to the directory. All of our employees are in that group so they can retrieve the files the customers upload to the server.

When the customer uploads a file to the server, the system is defaulting the permissions to 644. How do I get it so the permissions default to 660?

The second question is that when one of our employees places something in the customer's directory via SSH the server assigns it the userid and the primary group of the uploader? How do we get the system to use the parent directories owner and group instead of the uploaders? There are times when we need to place something in the customer's directory for them to retrieve.

The end result is that each customer has their own private directory that other customers can't access but our employees can. Both employees and customers should be able to create, delete, and modify the contents of the individual directories.

I have tried setting the setUID (chmod -R u+s /path to customer directory/customer directory) and setGID (chmod -R g+s /path to customer directory/customer directory)  bits but it is not doing what I expect them to do.
0
TimesNews
Asked:
TimesNews
  • 2
1 Solution
 
ropennerCommented:
umask for SFTP is the issue I think.  It may use root's umask so you can override that with the below:

change the Subsystem line in your sshd_config to this:

Subsystem sftp /bin/sh -c ‘umask 0002; /usr/libexec/openssh/sftp-server’

check for further explanations of setting up shells around sftp for umask
   http://jeff.robbins.ws/articles/setting-the-umask-for-sftp-transactions
0
 
TimesNewsAuthor Commented:
Based on the documentation for sshd_config changing the subsystem will remove the in process sftp server and corresponding chroot jail. Since out customers will be access this system, chanigng the subsystem line to use the openssh sftp server is not an option.
0
 
TimesNewsAuthor Commented:
It looks like the documentation for openssh was incorrect. The comment by ropenner worked.
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now