In exchange 2010 when after SSL cert installation, I still get "The name on the security certificate is invalid or does not match the name of the site.

I'm Installing Exchange 2010 with Outlook 2010 and I'm getting an error msg when starting outlook.

"The name on the security certificate is invalid or does not match the name of the site."

I used the wizard that had all proper names and server names, URLs, etc. Please advice what should I do to eliminate this error. Any help is greatly appreciated.

Who is Participating?
Alan HardistyConnect With a Mentor Co-OwnerCommented:
Personally, I use the following tool to generate the CSR:

Once generated, I copy the CSR tool output and paste it into the EMS (Exchange Management Shell), then copy the output file to the Certificate Authority.  Once generated, I download the cert, import it and then enable it all through the EMS.

Alan HardistyCo-OwnerCommented:
What names did you include in your certificate?

They should have been: (or whatever you chose)

If you don't have those names, please re-key the certificate to include them.

ibozcAuthor Commented:
the question I have for you then is, where exactly do I place them? Which fields? I used the Exchange wizard and it had many options, which of those fields should hold this info? Thx.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.