Solved

On first try with each  Asterisk SIP call, they can't hear me but I can hear them, but on second call everything is fine

Posted on 2011-02-11
14
562 Views
Last Modified: 2012-06-27
This is a continuation of my closed question. The problem persists. Everything in my previous question still applies. I have forwarded pots 5060 and UDP 10000-20000 to the asterisk server. I have read that usually this a port forwarding issue but could also be a codec issue.
0
Comment
Question by:Jeff swicegood
  • 9
  • 5
14 Comments
 
LVL 76

Expert Comment

by:arnold
ID: 34876010
Double check your QoS policy making sure you have prioritized SIP traffic on the WAN side.
http://www.dd-wrt.com/phpBB2/viewtopic.php?p=14124
0
 
LVL 1

Author Comment

by:Jeff swicegood
ID: 34876496
Ok. QoS is enabled. (The reason I thought QoS didn't work well on this router before is that I put the downlink speed in the uplink box and vice versa, making everything slow to a crawl).

Please forgive the lag in communication as I test it for a few days.
0
 
LVL 1

Author Comment

by:Jeff swicegood
ID: 34901086
QoS is functioning nicely, but I'm afraid the problem still persists on about half the calls. And it happens when there is hardly any traffic on the LAN (to and from WAN).
0
 
LVL 76

Expert Comment

by:arnold
ID: 34901805
Double check the iptables  rules on the wrt and see if you can move up the SIP processing higher in the filter rules.
Do you have asterisk connected directly to the wrt device or is it plugged into the network switch ? Does the network switch have QoS capabilities or can you move the asterisk to the router?
i.e. if all data is coming through on one hose, it is harder to prioritize one type of traffic versus another.
0
 
LVL 1

Author Comment

by:Jeff swicegood
ID: 34908602
I just now moved SIP and RTP to the top of the list in the Services Priority section of the GUI. I'm assuming it's better to do it from command line. What are the commands?

At any rate I'll test it now.

Asterisk is in a Virtual Machine on a host that is connected directly to the wrt router. Moving it to the router is more than I can get into right now. Right now it's neatly packaged in a distro called Trixbox along with Freepbx and a lot of other tools.

What I could possibly do is get the  other NIC working onthe host and give the VM it's own NIC connected directly to the wrt router.
0
 
LVL 76

Expert Comment

by:arnold
ID: 34909051
one way is to use
iptables -L --line-numbers
This will list your iptables rules and chains.


then insert the rule above at a specified number
iptables -I <INPUT|OUTPUT|FORWARD|..> rule_number rule

I'm not sure whether there is a way to move rules within iptalbes i.e. shifting a rule from position 10 to position 5.
You could bridge the second host NIC to the VM's NIC

0
 
LVL 1

Author Comment

by:Jeff swicegood
ID: 34928626
When I use iptables -L --line-numbers the only rules I see listed for SIP are the ports I forwarded. I do not see any QoS info. Do you mean to move those forwarded ports rules higher? Out put attached iptables-rules
0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 
LVL 76

Accepted Solution

by:
arnold earned 250 total points
ID: 34930803
0
 
LVL 1

Author Comment

by:Jeff swicegood
ID: 34930998
According to the the output from cat /proc/net/ip_conntrack QoS was not enabled on my SIP and RTP connections, nor could I get it to enable even though I entered it into the gui several times. Finally, I I set the mac address to premium QoS, and it now shows premium on my connections. I will test it on calls.
0
 
LVL 1

Author Comment

by:Jeff swicegood
ID: 34943051
So far it has been the same problem. The VM is now bridged to the second NIC. I will test it.
0
 
LVL 1

Author Comment

by:Jeff swicegood
ID: 34946465
How to keep the host(Ubuntu) traffic off the second NIC? I see that iptables is already there in Ubuntu--should I use that?
0
 
LVL 76

Expert Comment

by:arnold
ID: 34956266
If you do not define an IP on the second NIC within Ubuntu it will not have a record of it nor an entry in the routing table.
route print or netstat -rn.

Are the iptables rules block access to the second NIC?
0
 
LVL 1

Author Comment

by:Jeff swicegood
ID: 34957213
Well, that part worked like a charm! I just disconnected eth3 in network manager and all host traffic stopped on that interface, while the Trixbox traffic remained. Now to test it with calls again...
0
 
LVL 1

Author Comment

by:Jeff swicegood
ID: 34987041
Well, it has been four days without a mal-connected call. I guess we can call this question closed. Thank you very much!
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Hey there Heard about jingle, the add on for XMPP that enables point to point audio between two XMPP clients. No server config necessary. Actually quite a cool feature. However, how good is it if you can not use those voice capabilities to do a P…
If your business is like most, chances are you still need to maintain a fax infrastructure for your staff. It’s hard to believe that a communication technology that was thriving in the mid-80s could still be an essential part of your team’s modern I…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now