Solved

XP SP3 and IE 8 cannot connect remotely through RWW on SBS 2008

Posted on 2011-02-11
5
612 Views
Last Modified: 2012-05-11
I have an XP Pro SP3 x86 laptop that will not connect to a remote computer through RWW running on SBS 2008. Numerous other remote users have no problems. The error message is as follows:

“The Microsoft Terminal Services Client ActiveX control (also known as Microsoft RDP Client Control) is either not available, or is not enabled. For more information about installing and enabling this ActiveX control, see the Microsoft TechNet Web site (http://go.microsoft.com/fwlink/?LinkId=103719).”

I have performed all of the suggestions from this MS article, http://support.microsoft.com/default.aspx?scid=kb;EN-US;951607, and nothing helped. The ActiveX does not even show up in the Add-in manager. Resetting IE8, even reinstalling IE8, did nothing. Deleting all those registry keys and doing the “Fix It” utility did nothing. The site has been added to the laptop’s Trusted Sites, and the security has been customized for Trusted Sites to allow ActiveX prompting and installation. I have tried to install the RDP client manually, but the error is that the SP level of XP is beyond the client version, and it would not install.

I am at a loss here. Everything that should work, doesn’t. Any suggestions? I will be monitoring the thread consistently until I can correct this.
0
Comment
Question by:MISquared
  • 3
  • 2
5 Comments
 
LVL 77

Accepted Solution

by:
Rob Williams earned 250 total points
ID: 34876259
You mentioned you tried updating the RDP client, which version, it needs to be 6.0 or newer, the latest for XP being 6.1
http://www.microsoft.com/downloads/en/details.aspx?FamilyId=6E1EC93D-BDBD-4983-92F7-479E088570AD&displaylang=en

The following is a common RWW repair web page that may be of help
http://www.sbslinks.com/fixmyrww.htm
0
 
LVL 2

Author Comment

by:MISquared
ID: 34876284
Thanks for your reply RobWill.

It was 6.1. I ran it again, and the exact error message is "Setup has detected that the Service Pack version of this system is newer than the upate you are applying. there is no need to install this update." The only option is "OK", which closes the dialogue box.

I should also correct my earlier claim that it is a Pro OS. It is actually Home. I don't think it is relevant, but I thought I should mention it.
0
 
LVL 77

Assisted Solution

by:Rob Williams
Rob Williams earned 250 total points
ID: 34876421
Home is fine, did you have any luck with any options from the fixmyrww link I provided? I noticed according to it and the link to MS they provide the ver 7 client will work as well on XP. I didn't realize that.

A common fix when the TS add-on is no present is in IE to go to tools | internet options | advanced | click reset | close and re-open IE
0
 
LVL 2

Author Closing Comment

by:MISquared
ID: 34876521
Great, it was the RDP 7 client that did it. Thanks, RobWill!
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34876533
Excellent. Glad to hear.
Thanks MISquared.
Cheers!
--Rob
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

If you have done a reformat of your hard drive and proceeded to do a successful Windows XP installation, you may notice that a choice between two operating systems when you start up the machine. Here is how to get rid of this: Click Start Clic…
For both online and offline retail, the cross-channel business is the most recent pattern in the B2C trade space.
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now