Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 631
  • Last Modified:

XP SP3 and IE 8 cannot connect remotely through RWW on SBS 2008

I have an XP Pro SP3 x86 laptop that will not connect to a remote computer through RWW running on SBS 2008. Numerous other remote users have no problems. The error message is as follows:

“The Microsoft Terminal Services Client ActiveX control (also known as Microsoft RDP Client Control) is either not available, or is not enabled. For more information about installing and enabling this ActiveX control, see the Microsoft TechNet Web site (http://go.microsoft.com/fwlink/?LinkId=103719).”

I have performed all of the suggestions from this MS article, http://support.microsoft.com/default.aspx?scid=kb;EN-US;951607, and nothing helped. The ActiveX does not even show up in the Add-in manager. Resetting IE8, even reinstalling IE8, did nothing. Deleting all those registry keys and doing the “Fix It” utility did nothing. The site has been added to the laptop’s Trusted Sites, and the security has been customized for Trusted Sites to allow ActiveX prompting and installation. I have tried to install the RDP client manually, but the error is that the SP level of XP is beyond the client version, and it would not install.

I am at a loss here. Everything that should work, doesn’t. Any suggestions? I will be monitoring the thread consistently until I can correct this.
0
MISquared
Asked:
MISquared
  • 3
  • 2
2 Solutions
 
Rob WilliamsCommented:
You mentioned you tried updating the RDP client, which version, it needs to be 6.0 or newer, the latest for XP being 6.1
http://www.microsoft.com/downloads/en/details.aspx?FamilyId=6E1EC93D-BDBD-4983-92F7-479E088570AD&displaylang=en

The following is a common RWW repair web page that may be of help
http://www.sbslinks.com/fixmyrww.htm
0
 
MISquaredAuthor Commented:
Thanks for your reply RobWill.

It was 6.1. I ran it again, and the exact error message is "Setup has detected that the Service Pack version of this system is newer than the upate you are applying. there is no need to install this update." The only option is "OK", which closes the dialogue box.

I should also correct my earlier claim that it is a Pro OS. It is actually Home. I don't think it is relevant, but I thought I should mention it.
0
 
Rob WilliamsCommented:
Home is fine, did you have any luck with any options from the fixmyrww link I provided? I noticed according to it and the link to MS they provide the ver 7 client will work as well on XP. I didn't realize that.

A common fix when the TS add-on is no present is in IE to go to tools | internet options | advanced | click reset | close and re-open IE
0
 
MISquaredAuthor Commented:
Great, it was the RDP 7 client that did it. Thanks, RobWill!
0
 
Rob WilliamsCommented:
Excellent. Glad to hear.
Thanks MISquared.
Cheers!
--Rob
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now