Solved

OWA Broken, No Email inbound or outbound after installing MSCRM Email Router

Posted on 2011-02-11
8
1,131 Views
Last Modified: 2012-05-11
Installed MSCRM Email Router on same machine as the CRM installation
Exchange server(2007) on seperate machine.
Exchange edge server(2007) on seperate machine.

Confiugred Email router on CRM server.
Tested Email router received errors in testing

Mailbox not found (access test succeeds)

Symptom: When you click Test Access in the E-mail Router Configuration Manager, the test succeeds. However, you receive HTTP 404 errors in the application event log when the E-mail Router processes e-mail messages. Check the IIS logs for the following error:

Request Filtering: Denied because URL doubled escaping 404.11

Resolution: Run the following command on the Exchange Web site to allow double escaping:

%windir%\system32\inetsrv\appcmd set config "Default Web Site" -section:system.webServer/security/requestfiltering -allowDoubleEscaping:true


Obtained the above statement from http://rc.crm.dynamics.com/rc/regcont/en_us/op/articles/tshootrouter.aspx


Ran the above command in the exchange management shell on the Exchange server
Now cannot browse web / ping / tracert from the exchange server.
Cannot email to the outside world. Internal emails work

Ran
 %windir%\system32\inetsrv\appcmd set config "Default Web Site" -section:system.webServer/security/requestfiltering -allowDoubleEscaping:false

Unistalled MSCRM Email router

Still not working.
0
Comment
Question by:NCPros
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 2
8 Comments
 
LVL 26

Expert Comment

by:e_aravind
ID: 34882851
Want to give a try by changing the appcmd command:

Go to Start -> Run ->cmd-> cd \windows\system32\inetsrv
C:\windows\system32\inetsrv> appcmd set config /section:requestfiltering /allowdoubleescaping:true
0
 

Author Comment

by:NCPros
ID: 34892917
firewall was blocking me but still OWA wont work.
I recieve an error when I attempt to browse the owa from the IIS on the Exhange.
https://127.0.0.1/owa
"There is a problem with this website's security certificate."

Below is the the links to
Click here to close this webpage
Continue to this website(not recommended)

If we click the continue to this website link we get
Internet Explorer cannot display the webpage
   
   Most likely causes:
You are not connected to the Internet.
The website is encountering problems.
There might be a typing error in the address.  

Re-installed OWA still the same any suggestions.
0
 

Author Comment

by:NCPros
ID: 34892923
Yes we are using SSL
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 26

Expert Comment

by:e_aravind
ID: 34896452
ON E2k7 console, change the internal URLs to have http:\\FQDN-of-server\owa
On IIS, DWS and \OWA v.directory remove the "Require SSL"

Then try checking the same using http:\\servername\owa
0
 

Author Comment

by:NCPros
ID: 34898110
Tried
ON E2k7 console, change the internal URLs to have http:\\FQDN-of-server\owa
On IIS, DWS and \OWA v.directory remove the "Require SSL"

Then try checking the same using http:\\servername\owa 
Still not working.

Setup new website and setup owa applications on it now  receiving error 500.22 and have spent last few hours trying to get it to work still nothing.

HTTP Error 500.22 - Internal Server Error
An ASP.NET setting has been detected that does not apply in Integrated managed pipeline mode.

Module ConfigurationValidationModule
Notification BeginRequest
Handler StaticFile
Error Code 0x80070032
Requested URL https://127.0.0.1:443/owa/ 
Physical Path C:\Program Files\Microsoft\Exchange Server\ClientAccess\Owa\
Logon Method Not yet determined
Logon User Not yet determined

I know that the OWA that worked was using Integrated Mode for the application pool.
0
 

Accepted Solution

by:
NCPros earned 0 total points
ID: 34917282
Restored backup
0
 

Author Comment

by:NCPros
ID: 34917304
.
0
 

Author Closing Comment

by:NCPros
ID: 34949696
Restored backup fixed all issues
0

Featured Post

Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
In-place Upgrading Dirsync to Azure AD Connect
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question