Remote desktop on server 2008

Hi,
I am running remote desktop internally on my lan on almost all the servers and thats ok.  When I come home and type in the external IP of the servers in Remote desktop they ask me username and pass and I can remote desktop directly.  I want to use Remote desktop only on my  LAN and not externally.  WHat is wrong and how can I fix it.  Is this a major issue that I shoul d be concerned?  

Help plz  
LVL 5
amanzoorNetwork infrastructure AdminAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
mail2divyeshConnect With a Mentor Commented:
You need to have a Firewall to block RDP (TCP port 3389). Or if your company already has a FW, ask the admin to block the RDP via FW.
0
 
mail2divyeshCommented:
To add, its certainly a major issue as it means anyone from outside can just do a simple port scan and try to connect to your company's servers. Infact that can even brute force to break in..!
0
 
mahrens007Connect With a Mentor Commented:
agree with mail2divyesh - there are some ports forwarding enabled on the firewall.  What they could do is lock it down to a certain IP address (IE your house) so you can only RDP into it from the outside.  Just remember, since you probably have a dynamic IP, the firewall will have to be updated to your new IP address.
0
 
amanzoorNetwork infrastructure AdminAuthor Commented:
Thanks guys:
THe access-list was not applied to my internet interface.
Solved.
0
All Courses

From novice to tech pro — start learning today.