Link to home
Start Free TrialLog in
Avatar of bmc360
bmc360

asked on

Exchange 2010 Install Fails

During the setup of Exchange 2010 into an existing Exchange 2007 Organisation I get the following error when setup has completed -



Mailbox Role
Failed

Error:
The following error was generated when "$error.Clear(); $arbUsers = @(get-user -Filter {lastname -eq "MSExchApproval 1f05a927-3be2-4fb9-aa03-b59fe3b56f4c"} -IgnoreDefaultScope -ResultSize 1); if ($arbUsers.Length -ne 0) { $mbxname = $arbUsers[0].name; $mbxs = @( get-mailbox -arbitration -Filter {name -eq $mbxname} -IgnoreDefaultScope -resultSize 1 ); if ( $mbxs.length -eq 0) { $dbs = @(get-MailboxDatabase -Server:$RoleFqdnOrName -DomainController $RoleDomainController); if ($dbs.Length -ne 0) { enable-mailbox -Arbitration -identity $arbUsers[0] -database $dbs[0].Identity; } } }" was run: "No provisioning handler is installed.".

No provisioning handler is installed.

Elapsed Time: 00:02:29


Finalizing Setup
Cancelled


Any help greatly appreciated.

Thanks.
Avatar of mass2612
mass2612
Flag of Australia image

Hi,

What is the patch level, etc of the Exchange setup files you are installing from and what version of Windows are you installing onto? Such as Windows 2008 R2 or SP1, etc?
Avatar of bmc360
bmc360

ASKER

Hi, Installing from Exchange2010 SP1 media, have applied all the patches as MS recommend, onto Windows 2008 R2 server
ASKER CERTIFIED SOLUTION
Avatar of mass2612
mass2612
Flag of Australia image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of bmc360

ASKER

Yes, done all the AD pre-reqs, media was downloaded from MSDN
Avatar of bmc360

ASKER

Sorted, I was installing with different media than I had done the setup /preparead and setup /prepareschema.
Thanks
No worries. Can I ask was the schema updated via the Exchange 2010 RTM?
Avatar of bmc360

ASKER

It sure was!