Solved

insufficient disk space in datastore vmware server

Posted on 2011-02-12
16
4,328 Views
Last Modified: 2012-06-27
I am using vmware server 2.0 to run a windows 2k8 r2 server. It ran out of space (100gigs) so i increase the drive capacity additional 100 gigs. For some reason that additional 100 gig didn't get allocated to the VM. I am unable to extend the drive in the disk manager. however a 100 gig vmdk tmp file was created in the vm datastore folder taking up that space. Even with that i still have another 100 gigs free on the harddrive. So i try allocating another 20 gigs and i'm getting reconfigured virtual machine failed error. insufficient disk space in datastore. Any ideas?

Thanks you
0
Comment
Question by:my3cents
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
16 Comments
 
LVL 9

Expert Comment

by:MinoDC
ID: 34878590
0
 
LVL 28

Expert Comment

by:bgoering
ID: 34879487
After you modify the drive size to 200 GB in VMware edit settings on your virtual win 2k8 server, you also need to extend the volume from within the OS.

See http://technet.microsoft.com/en-us/library/cc771473.aspx for a procedure

Good Luck
0
 

Author Comment

by:my3cents
ID: 34880118
I try to extend it within windows but there are no space available. The extend option is greyed out. It seems like the vm server allocated 100 gig to a vdmk tmp file but that space is no where to be found in windows
0
The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

 
LVL 28

Expert Comment

by:bgoering
ID: 34880148
can you post a directory listing for the VM, as well as a screenshot of the Edit Settings page for the virtual HDD
0
 
LVL 28

Expert Comment

by:bgoering
ID: 34880151
And a screeshot of disk manager hilighting the drive in question
0
 
LVL 8

Expert Comment

by:markzz
ID: 34883434
It sounds as though you have added another disk to your Win2k8r2 guest rather than extend the current disk.
Check in the management interface under edit, do you have an additional disk assigned?
You may need to power down the guest, commit any snapshots then extend the disk.
Once extended power up the guest and in the windows diskmanager extend the 100GB disk from a Windows perspective.
You can also use diskpart to extend your disks in Windows.
0
 

Author Comment

by:my3cents
ID: 34888603
I'm pretty sure i extended the drive but something happened during the process. Attached are the screen shots. Thanks. vm directory
0
 
LVL 28

Accepted Solution

by:
bgoering earned 500 total points
ID: 34888650
Take a look at http://www.experts-exchange.com/Software/VMWare/Q_26159942.html#a32636843

Probably the easiest fix would to be to clone to a new vm with VMware Converter 4.3 standalone (http://www.vmware.com/products/converter)
0
 
LVL 28

Expert Comment

by:bgoering
ID: 34888704
Another thing to look at is vmware-vdiskmanager

User guide: http://www.vmware.com/pdf/VirtualDiskManager.pdf
0
 

Author Comment

by:my3cents
ID: 34888877
does anyone know if i can delete the "virtual machine .vmdk.dfgshkgrw-tmp" file that is taken up 100 gigs?
0
 
LVL 28

Expert Comment

by:bgoering
ID: 34889466
You probably can't if the VM is up.... And you definately should not with the vm down (at least until you have a good backup)

I would still try replicating it off the another box with vmware converter 4.3, Make sure it comes up there with workstation or player.

At that point you can delete it and use converter to put it back resizing the disk as you do so.
0
 

Author Comment

by:my3cents
ID: 34890012
bgoering,

i tried the solution from the link you provide and i got this message when i use the command prompt. Basically i'm trying to increase the volume by 1Gb. I can increase the disk space of another VM from the same datastore so i know there is available space.

C:\Program Files (x86)\VMware\VMware Server>vmware-vdiskmanager.exe -x 101Gb "c:
\vmware\datastore3\xxx\Virtual Machine.vmdk"

Failed to expand the disk 'c:\vmware\datastore3\xxx\Virtual Machine.vmdk':
 An error occurred while writing a file; the disk is full. Data has not been sav
ed. Free some space and try again (0xd00000008).

i'm still waiting for vmware to authorize me to download the converter.
0
 
LVL 28

Expert Comment

by:bgoering
ID: 34890966
I think to do the expand you need to have lots of free space on your datastore. Looking again at your screenshot where maximum capacity is 236 GB - that would mean you have 136 GB free on the datastore (original 100GB + 136GB to grow into for max size).

You try to increase by 100GB - to do that I believe the process is
Create -tmp volume same size as base disk (100 GB)
If successful copy old disk to -tmp for backup
If successful create 200GB new drive (can't because now only 36GB free)
If successful then copy old disk to new disk
If successful then delete old disk and rename new disk

Older products like vmware server and old versions of workstation were not very efficient in their use of disk space.

I still think Converter will be your best bet - would be afraid to try too much with that -temp file out there. If you wish to forge ahead with expand what you have - is there something else
0
 

Author Comment

by:my3cents
ID: 34891332
I tried to increase it by 1Gb and it still gives me error. I guess i will try the converter but i'm still waiting for VMware to give me access to the download.
0
 
LVL 28

Expert Comment

by:bgoering
ID: 34891461
OK, don't you already have an account from when you downloaded vmware server? Its been ages since I registered but don't recall it taking very long...
0
 

Author Closing Comment

by:my3cents
ID: 34961473
The disk manager failed but the converter worked for me. Thanks for all the help.
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If we need to check who deleted a Virtual Machine from our vCenter. Looking this task in logs can be painful and spend lot of time, so the best way to check this is in the vCenter DB. Just connect to vCenter DB(default DB should be VCDB and using…
Giving access to ESXi shell console is always an issue for IT departments to other Teams, or Projects. We need to find a way so that teams can use ESXTOP for their POCs, or tests without giving them the access to ESXi host shell console with a root …
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question