SBS 2008, Exchange 2007 not receiving external email

This is a fresh install of SBS 2008 with Exchange 2007.  Owa works correctly internally and externally. I can send email from the internal server to external email addresses.  I cannot sent external emails and receive them internally to the exchange server.  I opened IE on the server and went to canyouseeme.org and tested port 25 with Success.

When I send an email from gmail or yahoo to the email addresses on this exchange server I dont get any bounce back messages, but I am not receiving the emails either.

What do you think could be the reason?

Thanks in advance for your help.
gk2incAsked:
Who is Participating?
 
Glen KnightConnect With a Mentor Commented:
Have you completed all the wizards in the SBS COnsole? If not then this could be why.

Part of the wizards sets anonymous access on the Default receive connector.  Using the Exchange Management Console under Server Configuration > Hub Transport check the properties of the receive connector that starts with default.  Is the anonyouse check box checked? If not check it.

Also make sure port 25 is being forwarded to the internal IP address of the SBS server.
0
 
gk2incAuthor Commented:
Do you know, I went through all the wizards with Microsoft and the receive connectors and this whole time the receive connector was disabled!  LOL

Thank you for pointing me there so I could see that.  All is well now!  

:)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.