SBS2003, exchange keeps mail in queue when use DNS option is selected.

Hello,

Sorry for my english.
Here is a big problem. I read a lot of articles in forums but I never found solution.
I have SBS2003 and I am using Exchange 2003 SP2 on It.
I would like exclusively sending mails with DNS option selected not relaying with smart host.
I have a MX record in my DNS who is pointing to exchange server (WAN address).
NIC's DNS is pointing to Itself.
The smtp connector is configured with DNS option.
SMTP protocol : incoming mail is TCP 52525 and 25 for outgoing.
I receive mails from my customers.

I use authentication with mail client (mail (MAC OS X) and Outlook) Plain Text.
So, I can send any mails to any destinations if relay is open but when I am trying to prevent spamming (picture 1), mails stay in queue !

The only way to release the queue is to configure sending connector with smart host instead of DNS.
When the queue is cleared, I can configure with DNS option and send again (if the relay is open)

I tried Best practice tools, updates, kb, etc...
Lan, range IP:192.168.255.0/24
What's happening ? What are misconfigured

Thx in advance for suggestions

 Relay options, mails stay in queue SMTP Connector options Relay options-authenticated users, mails stay in queue Relay options-authenticated users, mails stay in queue Relay options, mails stay in queue LAN authorized, mails stay in queue LAN authorized, mails stay in queue
cpsoft7110Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Larry Struckmeyer MVPConnect With a Mentor Commented:
Bonjour!

Unfortunately, my French is much worse than your English, so if we are going to get anywhere with this it will have to be in English.  <g>

let me first recommend the usual things necessary to fix issues with SBS.  Once we  know that all of those things are good, we can look at more.

1.  Download, update, run the sbs bpa, and fix everything it finds.  www.sbsbpa.com
2.  Be sure you SBS is the DHCP server.
3.  Be sure that every nic in you network points to the internal nic in the SBS for DNS.
4.  Be sure that thei ISP furnished DNS servers are in the forwarders tab in the DNS management application start - admin tools - dns
5.  After that, run the CEICW and carefully fill in all the information.
6.  If mail still does not flow, open the exchange system manager and turn up the logging to see if you can capture more information.





0
 
cpsoft7110Author Commented:
Hello,
I performed every tasks you recommend in your post.
There is a 7th task : be sure a MX record in local DNS (SBS 2003) is pointing to wan ip address of the mails server.
And It Works !
Thanks for your help
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.