Solved

Companyweb on SBS 2008 machine - asks for user / password to connect

Posted on 2011-02-13
2
587 Views
Last Modified: 2012-06-27
On our sbs 2008 machine, whether on the server itself or a machine, it asks for a username / password to access companyweb.  Even using admin user / passes do not work

As Sharepoint / Companyweb is populated with data, what i would like to know is if this solution will affect any data in the database , or will it return to normal if successful?

http://technet.microsoft.com/en-us/library/dd548330(WS.10).aspx

Otherwise have you any other suggestions to resolve this?
0
Comment
Question by:bytemeal
2 Comments
 
LVL 10

Accepted Solution

by:
CSIPComputing earned 500 total points
ID: 34882481
I wouldn't recreate the companyweb, I'd fix the problem.

I seem to recall this is a problem with the authentication mode on Companyweb, and you need to change the authentication method rather than recreate the web site.

This URL may help: http://support.microsoft.com/kb/961143

You also may try this (which is a workaround I used on a client of mine).  This also sets the authentication method correctly.

I believe this problem is only seen on IE8, and is a known problem (Check the SBS 2008 Blogs)

Click Start, click Administrative Tools, Click SharePoint 3.0 Central Administration, and then click Continue on the User Access Control Dialogue.

In the Authentication Providers page, Click Application Management, and then click the "Authentication providers" under the "Application Security" tab

Check the Web Application, make sure the port is 987; otherwise change web application to the URL which has the port 987

Click the "Default" zone, you will go to the Edit Authentication page;

Check the Negotiate(Kerberos) option under the Integrated Windows authentication tab;

Click OK in the Dialog which gives a warning that "You have chosed to use Kerberos with Integrated Windows authentication. Manual configuration steps by a domain administrator will be required if the application pool's security account is not the Network Service" and then click Save;
0
 
LVL 1

Author Closing Comment

by:bytemeal
ID: 34885060
Very clear instructions and a perfect answer!
Activated Kerberos security and worked straight away

Have been battling with this one for a few days, thankyou, very much appreciated :)
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

I've often see, or have been asked, the question about the difference between the Exchange 2010 SP1 version, available as part of Small Business Server (SBS) 2011, and the “normal” Exchange 2010 SP1 Standard. The answer to the question is relativ…
Microsoft SharePoint Foundation 2010 and Microsoft SharePoint Server 2010 do not offer the option to configure the location of the SharePoint diagnostic trace log files during installation.  This can, however, be configured through Central Administr…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now