Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1657
  • Last Modified:

How do I set up an ftp server in Windows 7 Professional 64-bit?

I have a Canon EOS 7D with the WFT-E5 wireless file transmitter attached.   I want to set up FTP server in my computer so images download automatically to a folder on my computer.   How do I set up the FTP and what changes do I need to make to Windows firewall?   I also have AVG Antivirus Business Edition installed.   My computer is on a domain.
0
DoctorK12008
Asked:
DoctorK12008
  • 14
  • 14
  • 6
  • +1
2 Solutions
 
CuteadderCommented:
Firstly do you want the pictures to go to your computer? or onto the server that also holds your domain? presuming thats on 24/7?

Yes you will need to add a nat setting to your firewall...
0
 
AmickCommented:
Go to
Control panel
Select programs
Select Turn Windows features on or off
Select Internet Information Services
Select FTP Server (or if you don't want the extensions, open FTP Server and select FTP Service)
Click OK

You can manage FTP through the Control Panel System and Security IIS Administrative tool
0
 
AmickCommented:
To clarify my previous answer, the FTP "User Isolation" configuration feature allows you to specify a directory for a given user. As administrator, you decide what freedom they have.  You may want to require them to always use one directory, or you may want to allow them to create project subdirectories where all the files for a given project might be stored without concern that images for different projects would be inadvertently overwritten.   You are able to configure the server so that  once they've logged in they go to the directory you have specified, deposit their file, and it immediately becomes available to processes and users with appropriate privilege.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
David Johnson, CD, MVPOwnerCommented:
since the camera has an ftp server don't you really need an ftp client? you can use your browser with the url ftp://addressofcamera or use a client ie. wsftppro  or the dos ftp client start/run/ftp then use the ftp commands to grab the files and transfer them to your computer.
0
 
CuteadderCommented:
The camera would have a ftp client, to upload to a ftp server, the camera will not have a FTP server...

Amick's comment on 13/02/11 03:14 PM should solve the issue, but you will still need to give your computer a static IP and if using the camera over the internet rather than your local lan, you will need to change the firewall NAT settings.
0
 
David Johnson, CD, MVPOwnerCommented:
The Canon WFT-E5 Wireless File Transmitter has been launched alongside the Canon EOS 7D to offer the ability to wirelessly transmit images from your camera to a computer, and give enhanced remote capture, media server functionality and linked shooting.

The new WFT-E5 unit takes the Wi-Fi possibilities with the EOS 7D to a new level by offering advantages such as, 802.11a/b and g compatibility, DLNA compliance, an improved HTTP mode called WFT Server and Linked Shooting for remote shutter triggering of up to 10 other EOS 7D cameras.  

from their website http://cpn.canon-europe.com/content/product/accessories/wft_e5.do

0
 
CuteadderCommented:
looks good but I think you still need a FTP server...
0
 
DoctorK12008Author Commented:
Yes, I still need to set up a FTP server in the computer I want to use.   Can someone please provide step-by-step instructions for doing this?   I have no idea how to do it.   Thanks in advance!
0
 
CuteadderCommented:
Go to

Start
Control panel
Select programs
Select Turn Windows features on or off
Select Internet Information Services
Select FTP Server (or if you don't want the extensions, open FTP Server and select FTP Service)
Click OK

then go to start
type in cmd > press enter
type in ipconfig > press enter

the ip address is the address you give when the camera asks for a server address and use your usual username and password...
0
 
AmickCommented:
Since the step-by-step instructions for enabling your FTP server given above at  02/13/11 09:14 AM, ID: 34882884 were insufficient, I would like clarification about what you're not clear on.
0
 
DoctorK12008Author Commented:
OK, I've got as far as here (see file attached).   What do I enter under the various settings (FTP authorization, etc.)? Authorization
0
 
CuteadderCommented:
Anon Authentication - disabled
Basic Authentication - enabled.
0
 
David Johnson, CD, MVPOwnerCommented:
how does installing a ftp server on his computer get the files from the camera to his computer.. that is what the user wants..
0
 
CuteadderCommented:
the camera is able to connect to a wifi network then upload photos via ftp...
0
 
DoctorK12008Author Commented:
I keep getting an error message (error 45) saying the ftp server returned an error.   I am attaching the page from the manual showing what this error means.   Hope this helps.   I have tried turning off the Windows firewall, but that does not seem to make any difference. Error explanation
0
 
CuteadderCommented:
ok...

from your computer go to:

start > run > cmd

then type in

ftp 127.0.0.1

if it asks for a username give your windows username
if it asks for a password give your windows password

127.0.0.1 is your local computer, this is just to test if the ftp server is working... let me know what happens...
0
 
DoctorK12008Author Commented:
It says: "connection closed by remote host"
0
 
CuteadderCommented:
did it get to asking for a username?
0
 
DoctorK12008Author Commented:
No.   I found that if I disable Windows firewall on this computer and try to connect from another computer on the domain using IE and enter "ftp://192.168.0.29" it then asks for a username and password, however I tried my Windows password and it did not let me connect and kept asking for a username and password.
0
 
CuteadderCommented:
if your computer is on a domain, have you tried domain\username
0
 
DoctorK12008Author Commented:
OK, that works, but only if I disable Windows firewall.   How do I configure Windows firewall to allow the camera to connect?
0
 
CuteadderCommented:
Control Pannel > Windows Firewall > Allow a program or feature through > allow another program > 

see if you can find FTP or IIS

then click ok
0
 
DoctorK12008Author Commented:
Yes, I found FTP and checked the box.   Now I can connect from another computer using IE and my domain login, however, the camera still returns error 45 when I try to connect it.
0
 
CuteadderCommented:
hmm... not really sure now... I'll google the error 45, but not sure...
0
 
DoctorK12008Author Commented:
Please see jpeg file previously uploaded (yesterday 4:38 PM) for explanation of error message.   Hope this helps.
0
 
CuteadderCommented:
How is the camera connected to the network?
0
 
David Johnson, CD, MVPOwnerCommented:
try username anonymous password anyemail@whatever.com
then you should be able to connect.
0
 
DoctorK12008Author Commented:
It connects to a wireless router on the network.   I can use a Canon program, EOS Utility, that works OK and the files are downloaded to a folder on my computer, so I know there is no problem with the camera communicating with the router.   The problem seems to be getting the camera communication settings to coordinate with the FTP settings.   There seem to be so many variables, such as passive or active mode, proxy server, login method (anonymous vs. login password) that I cannot figure out how to match them up.   Sorry for the tediousness of this problem.
0
 
CuteadderCommented:
Passive and active is probably the problem...

can you change the setting on the camera?

if not I'll take you through changing it on the ftp server
0
 
DoctorK12008Author Commented:
I tried both passive and active, but this did not make any difference.   I found an error in the FTP that might throw some light on the problem.   I am attaching a JPEG of the screenshot.   I also set Anon Authentication as well as Basic Authentication to enabled.   FTP error
0
 
CuteadderCommented:
the second part of that error message relates to a file path...

have you specified to the camera or the server at any time a file path where it should drop the pictures?
0
 
DoctorK12008Author Commented:
The file path for the FTP is a folder on my desktop.   For some reason, the folder is marked as read only.   I tried to change this but it reverts to read only every time.   Not sure how to fix this, or if it makes any difference.
0
 
David Johnson, CD, MVPOwnerCommented:
are you saying the contents of the folder are marked read only or the directory shows as read only?
directory is normal.. files within the directory are not..

your error message is extraneous.. disregard the ftp server you installed on your computer.. you could uninstall it as it has nothing at all about getting files off of the camera onto your hard drive. The camera has a built in ftp server (they call it a http ftp server)

an idea is from the ftp client (in dos) try
o http://camera-ip-address
and see what happens?

you might want to try from explorer alone.. in the address bar type ftp://ftp.cameraipaddress and see what happens
0
 
DoctorK12008Author Commented:
The folder itself, not the individual files are marked read only.   How do I find the username and password for the FTP server on my computer?
0
 
David Johnson, CD, MVPOwnerCommented:
have you been able to copy the files from the camera to your computer via ftp.  The ftp server is only needed if you want to access the files on your computer from elsewhere.
0
 
DoctorK12008Author Commented:
No.   I have been trying to set up ftp to transfer the files automatically.   What I want to be able to do is have the ftp server on the computer running so when I turn on the camera and take a photo, it is transferred automatically to a folder on my computer.   That is why I bought the WFT-E5.   If I can figure out how to get the username and password for the ftp on the computer, I can put the info into the camera setup.
0
 
DoctorK12008Author Commented:
I discovered the problem with the username and password to connect to the ftp server.   The virtual keyboard on the camera does not have the character \, but only /, so, to log on, the syntax is normally domain\username.   Since the virtual keyboard lacks the \ character, the way to log on is domain/username.   Who knew?!
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 14
  • 14
  • 6
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now