Solved

Call a popup window after sql insert

Posted on 2011-02-13
11
585 Views
Last Modified: 2012-08-13
As part of my Procedure I first insert data to a sql Db and then i want to popUp a small 100 by 100 window which just has a print window that opens , it prints goes away an they go onto the next task.  THis worked good in 1.1 code but having trouble getting to work in 4.0 code.  what am I doing wrong here.


sql = "Insert tblSRpEventData (intPersonnelId, intUnitSRPId, intQuestionId, bitAnswer, strData, strRemarks, dtDoc, dtLogged, strlogged) VALUES (" & PersId & ", " & UnitID & ", " & AQuesId & ", " _
                    & "" & Aanswer.SelectedValue & ", '" & Adata.Text & "', '" & ARemarks.Text & "', '" & ADtdate.Text & "', '" & Date.Today & "', '" & userlogon & "')"

            insertUpdateDelete(sql)
        Next

        ClearAdminGrid()

My first method is to put a lable on the aspx page and call the label but nothing is happening.
 lbljavascript.Text = "<script language=javascript>window.open('../Reports/SRPIssues.aspx?id=" & SSN & " '', 'width=1 height=1 top=1 left=1');</script>"

The second methis is to try to do with page controls but can't seem to get he systax correct.
 Page.ClientScript.RegisterStartupScript("window.open('" + Request.ApplicationPath + "../Reports/SRpIsses.aspx?ID=" & SSN & " '" + 'Width=100,height=100');", True)

Open in new window

0
Comment
Question by:kdeutsch
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 3
11 Comments
 
LVL 16

Accepted Solution

by:
BurnieP earned 400 total points
ID: 34883859
Hi,

Try using ClientScript.RegisterClientScriptBlock like this :


ClientScript.RegisterClientScriptBlock(Me.[GetType](), "open", "<script type='text/javascript'>window.open('" + Request.ApplicationPath & "../Reports/SRpIsses.aspx?ID=" & SSN & "','Width=100,height=100');</script>")

Open in new window

0
 

Author Comment

by:kdeutsch
ID: 34883907
Hi,
It gives me an error of invalid argument then says liine 53 character 32.
ClientScript.RegisterClientScriptBlock(Me.[GetType](), "open", "<script type='text/javascript'>window.open('" + Request.ApplicationPath & "../Reports/SRpIsses.aspx?ID=" & SSN & "','Width=100,height=100');</script>")
0
 
LVL 16

Expert Comment

by:BurnieP
ID: 34883929
Hmmm..  Maybe it is the + in window.open('" +... Change it for &

ClientScript.RegisterClientScriptBlock(Me.[GetType](), "open", "<script type='text/javascript'>window.open('" & Request.ApplicationPath & "../Reports/SRpIsses.aspx?ID=" & SSN & "','Width=100,height=100');</script>")
0
Forrester Webinar: xMatters Delivers 261% ROI

Guest speaker Dean Davison, Forrester Principal Consultant, explains how a Fortune 500 communication company using xMatters found these results: Achieved a 261% ROI, Experienced $753,280 in net present value benefits over 3 years and Reduced MTTR by 91% for tier 1 incidents.

 

Author Comment

by:kdeutsch
ID: 34883976
Hi,
Still get the same thing Invlid argument.  The highlight starts at the
>window.open
and calls character 32
0
 
LVL 16

Expert Comment

by:BurnieP
ID: 34884083
Hi,

I am really confused because it is working fine on my side.  Hmmm...  it might not like the <script tags..  I removed them, maybe..

ClientScript.RegisterClientScriptBlock(Me.[GetType](), "open", "window.open('" & Request.ApplicationPath & "../Reports/SRpIsses.aspx?ID=" & SSN & "','Width=100,height=100');")
0
 
LVL 11

Expert Comment

by:SAMIR BHOGAYTA
ID: 34886708
Hi, You have to use this code after insert query is executed.

using System.Windows.Form;

MessageBox.Show("Record successfully added");
0
 

Author Comment

by:kdeutsch
ID: 34896413
BurnieP,

Do you have working in an update panel on your side.  I have in an update panel, these things are a pain.
0
 

Author Comment

by:kdeutsch
ID: 34896429
samirbhogayta:

If I use form controls is messes up all my web page controls when I do this my code behind goes crazy with all kins os blue underlines.
0
 

Author Comment

by:kdeutsch
ID: 34896574
hi,
Ok this works and calls the a javascript alert window after the insert .
 ClientScript.RegisterStartupScript(Me.GetType(), "ClientScript", "alert ('hello')", True)
0
 

Author Comment

by:kdeutsch
ID: 34896728
hi,
Ok this is what I get for the link when it trys to open I get an javascript error on the bottom of the page in corner.  if I put the link into my page it works fine, but what I see is missing and I guess I don't know if its a problem is the server name and http before this part.
'/ReadinessTracker/Reports/SRPIssues.aspx?

maybe that information fills in automatically.??

<script type='text/javascript' window.open('/ReadinessTracker/Reports/SRPIssues.aspx?ID=10','Width=100,height=100');</script><script type='text/javascript'>new Sys.WebForms.Menu({ element: 'mnuMaster', disappearAfter: 500, orientation: 'horizontal', tabIndex: 0, disabled: false });</script>
0
 

Author Closing Comment

by:kdeutsch
ID: 34897217
Ok, the script works, to a point in that its not the script giving me the error, it has to do with my master page menu system and that I had misspelled link address.
0

Featured Post

Forrester Webinar: xMatters Delivers 261% ROI

Guest speaker Dean Davison, Forrester Principal Consultant, explains how a Fortune 500 communication company using xMatters found these results: Achieved a 261% ROI, Experienced $753,280 in net present value benefits over 3 years and Reduced MTTR by 91% for tier 1 incidents.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Calculating holidays and working days is a function that is often needed yet it is not one found within the Framework. This article presents one approach to building a working-day calculator for use in .NET.
It was really hard time for me to get the understanding of Delegates in C#. I went through many websites and articles but I found them very clumsy. After going through those sites, I noted down the points in a easy way so here I am sharing that unde…
In a recent question (https://www.experts-exchange.com/questions/29004105/Run-AutoHotkey-script-directly-from-Notepad.html) here at Experts Exchange, a member asked how to run an AutoHotkey script (.AHK) directly from Notepad++ (aka NPP). This video…
Attackers love to prey on accounts that have privileges. Reducing privileged accounts and protecting privileged accounts therefore is paramount. Users, groups, and service accounts need to be protected to help protect the entire Active Directory …

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question