Link to home
Start Free TrialLog in
Avatar of castellansolutions
castellansolutionsFlag for United States of America

asked on

Exchange 2010; Add Mailbox permission for a USER to the Members of the group

Hey All

Hoping i can get some help here. I have the following group (Mailenabled DistroGroup)

ForwardingGroup (email is forwardinggroup@mydomain.com)

Number of users 15

I wanted to be able to add my

domain\robert account to all members of the group with full mailbox access. I tried using this command:

[PS] C:\Program Files\Microsoft\Exchange Server\v14\Scripts>Get-DistributionGroupMember -Identity "ForwardingGroup" | Ad
d-MailboxPermission -user "domain\robert" -AccessRights FullAccess -InheritanceType All

But the EMS just sits there and doesnt do anything

Avatar of J P
J P
Flag of Australia image

for what you are trying to do, syntax wise your command is correct
i have run in my sandbox and it succeeded okay

what happens when you run just
Get-DistributionGroupMember -Identity "ForwardingGroup"

Open in new window


what happens when you run it for one user of the group
Get-Mailbox -Identity "A_User_In_ForwardingGroup" | Add-MailboxPermission -user "domain\robert" -AccessRights FullAccess -InheritanceType All

Open in new window


trying a process of elimination...
thinking maybe not enough permissions or something bad with the shell...
ASKER CERTIFIED SOLUTION
Avatar of castellansolutions
castellansolutions
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
yes, i read your question over and  that command is probably the most easiest/efficient way to achieve it

i run vm's for tests also.. with 8gb.. around 1-1.5gb max for exchange can pass.. client machines 384-512mb max should do it
Avatar of castellansolutions

ASKER

Thanks for the reponse. I just upgraded to 12GB of RAM (Yesterday) and now things are working like there supposed to.
Avatar of Glen Knight
This question has been classified as abandoned and is being closed as part of the Cleanup Program. See my comment at the end of the question for more details.