?
Solved

Outlook 2007 prompting for username/password when opened

Posted on 2011-02-14
10
Medium Priority
?
851 Views
Last Modified: 2012-05-11
Hello,

We have an environment that exists of the following:

SBS2008
Clients: Win 7 w/ Outlook 2007

When clients open Outlook 2007, they are prompted for a username and password. The title bar in the prompt says: Connect to mail.contoso.com (the external URL for the mailserver) Then Welcome to mail.contoso.com. Entering the domain credentials of domain\username and password works fine, however, the prompt will come back periodically and is obviously not ideal.

I have (to my knowledge) exhausted suggestions with Autodiscover and have upgraded to Exchange SP2 using the SBS Exchange SP2 installation tool. This hasn't made any difference. This is what I get when testing outlook autoconfiguration:

Protocol: Exchange RPC
SERVER: sbserver.domain.local
Login Name: User
Availability Service URL: https://mail.contoso.com/ews/exchange.asmx
OOF URL: https://mail.contoso.com/ews.exchange.asmx
OAB URL: https://mail.contoso.com/oab/a531fcb0-e0c9-4b10-9424-31b4b2e03ba7/
Unified Message Service URL: https://mail.contoso.com/unifiedmessaging/service.asmx
Auth package: Unspecified

Protocol Exchange HTTP
Server: different.contoso.com (This is an external address but appears to be the default one, IE: remote.domain.com, for some reason)
Login Name: User
SSL: Yes
Mutual Authentication: Yes
Availability Service URL: https://different.contoso.com/EWS/Exchange.asmx
OOF URL: https://different.contoso.com/EWS/Exchange.asmx
OAB: URL: https://mail.contso.com/OAB/a531fcb0-e0c9-4b10-9424-31b4b2e03ba7/ (note this one is the correct external FQDN)
Unified Messaging Service: https://different.contso.com/UnifiedMessaging/Service.asmx
Auth Package: Basic
Certificate Principal Name: msstd:different.contoso.com
0
Comment
Question by:puterssupport
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
  • +1
10 Comments
 
LVL 5

Expert Comment

by:zippybungle2003
ID: 34887036
Do you run a proxy server for the clients? are the addresses above exlcluded in the proxy settings in IE
0
 

Author Comment

by:puterssupport
ID: 34887043
Hello
Thank you for taking the time to reply
There is no proxy set up.

0
 
LVL 6

Expert Comment

by:chlebi
ID: 34887054
I remember I had this issue on sbs2008 and Win7/Outlook 2010 clients. There is a known bug there which already should be fixed (MS released an update for this).
Make sure you install all updates to the server via Windows Update and also update your clients (including Office) so it contains all latest service packs and updates.
0
Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 
LVL 5

Expert Comment

by:zippybungle2003
ID: 34887082
Under server manager, roles, IIS, do you have a tick in windows authentication aswell as basic authentication?
0
 

Author Comment

by:puterssupport
ID: 34887095
Hello,

I can confirm that the server/clients are up to date.

zippy, to which app pool/web site are you referring for the authentication? I believe I have been through this as per suggestions seen elsewhere and modified the authentication methods accordingly.
0
 
LVL 5

Expert Comment

by:zippybungle2003
ID: 34887129
0
 

Author Comment

by:puterssupport
ID: 34887186
Hi,

I've followed that, all seems in order. Outlook still prompts for a username and password.

Does the autoconfiguration output that I posted originally seem okay then?
0
 
LVL 7

Assisted Solution

by:Abbas Haidar
Abbas Haidar earned 1000 total points
ID: 34887535
install exchange 2007 SP3
0
 
LVL 6

Accepted Solution

by:
chlebi earned 1000 total points
ID: 34887837
Agree with absi81 - as I mentioned before, install ALL updates and then let's see... I had these issues and they are gone after updating.
0
 

Author Closing Comment

by:puterssupport
ID: 34896196
The problem is now solved.

I deleted the associated certificates and ran the fix my network task. Then re-added the certificate and rebooted the server.

Incidentally, the server was not rebooted after the installation of SP2 (no prompt requesting it) So it's most likely to do with that.

Thanks for all your help
0

Featured Post

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Changing a few Outlook Options can help keep you organized!
Check out this step-by-step guide for using the newly updated Experts Exchange mobile app—released on May 30.
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
Suggested Courses
Course of the Month7 days, 19 hours left to enroll

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question