Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4357
  • Last Modified:

Windows Server 2008R2 - Remote Control User Session. Session (id x)Remote Control Failed?

Hello all,

I am having an issue when trying to remote control a user session on Windows Server 2008R2.

If I log onto the system as the domain Administrator, I am able to control the session of users. However If I log onto my own account as Domain Admin, member of the Administrator group. I recieve an error which is:

Windows Task Manager:
Session (ID x) Remote Control Failed

There are many Domain Admins in my organization - which means we can't all simply log on as the Domain Administrator to our servers.

How can I enable Remote Desktop Session Shadows on all of my Domain Admin accounts?

Thank you for your time.
0
colinharris
Asked:
colinharris
  • 7
  • 4
3 Solutions
 
CuteadderCommented:
Do you have permissions to?
Are you connecting to the session from within a TS session?
0
 
colinharrisAuthor Commented:
Hi Cuteadder,

I am connecting to the TS session via RDP - Once logged in I then use the Task Manager > Users Tab - to remote control the user in question. It is then when I am faced with the session error.

However, if I do this same process using the Domain Admin account - it works.

I am a member of the Domain Admin group, which is also a member of the Administrators group on the Server.

Thanks for your quick reply.
0
 
CuteadderCommented:
if you go into...

Remote Desktop session host config > RDP-TCP > properties > sessions tab and remote control tab

are these options set for you to be allowed to take control and take control without the users permissions?

0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
colinharrisAuthor Commented:
Under the Sessions Tab:

Both of the Override User Settings boxes are un-ticked.

Under the Remote Contorl Tab:

All options are greyed out.

I am currently looking at these settings as the Domain Administrator.

Thanks.
0
 
CuteadderCommented:
Tick as many of those boxes as you can...

start a new RDP session and try again...

both the users and the admins RDP session needs to be started again...
0
 
colinharrisAuthor Commented:
Thanks for your input, however i'm afraid this hasn't worked.

This must be down to a R2 issue.

If anyone has any further information, that would be great?

Thanks.
0
 
colinharrisAuthor Commented:
*UPDATE*

I found the soloution to this annoying problem.

It was the UAC controlls. I disabled UAC and have been able to control users sessions.

0
 
CuteadderCommented:
That's interesting, thank you for letting us know!
0
 
colinharrisAuthor Commented:
I did not accept Cuteadders comment #34887459

The accepted solution is #34914724.

I don't know where thi
0
 
colinharrisAuthor Commented:
Finalised and closed.
0
 
colinharrisAuthor Commented:
This is the working soloution.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

  • 7
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now