Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Connect to SQL Server (on host) from vmWare Workstation 7.1.3

Posted on 2011-02-14
2
Medium Priority
?
3,483 Views
Last Modified: 2012-08-13
I'm trying to connect to my SQL Server 2008 R2 server on my host OS.

I'm running a vmWare Windows XP instance. The host OS is Windows 7 Ultimate.

On the host, I've installed SQL Server 2008 R2. From the host, I can successfully connect to that server and the databases on it using local .NET apps, Management Studio, and several other utilities.

I cannot connect to that SQL Server from my vmWare Windows XP instance. I can successfully connect to the host through the "Network Places" section on my vmWare instance, and I can browse shared folders on the host. I've tried connecting through an Access application, an through a VB.NET apps. Both are apps I wrote, and both can connect to the SQL server if I run those apps on the host OS.

I also tried to build an ODBC connection using the ODBC Data Source Administrator, trying both a File and System DSN, and using Windows and SQL Authentication. The Server is set to handle both types of authentication. The server is also set to allow remote connections.

I'm using NAT in the Network Adapter settings. I've tried the Bridged and host-only settings, with no luck. I've turned the Windows Firewall OFF on both the host and guest.

I'm obviously missing something, but have no idea what. Any assistance would be greatly appreciated.
0
Comment
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 17

Accepted Solution

by:
paulop1975 earned 2000 total points
ID: 34889488
Do you have TCP/IP enabled on SQL Server 2008?
Start > All Programs > Microsoft SQL Server 2008 > Configuration Tools > SQL Server Configuration Manager.
 SQL Server TCP/IP Enabled
0
 
LVL 85
ID: 34889706
Yes I do. However, I did NOT have "Named Pipes" enabled. I did that, restarted the service, and I can now connect.

Thanks!
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Giving access to ESXi shell console is always an issue for IT departments to other Teams, or Projects. We need to find a way so that teams can use ESXTOP for their POCs, or tests without giving them the access to ESXi host shell console with a root …
It’s time for spooky stories and consuming way too much sugar, including the many treats we’ve whipped for you in the world of tech. Check it out!
Viewers will learn how the fundamental information of how to create a table.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

598 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question