Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Can't Open Attachment in Outlook

Posted on 2011-02-14
9
2,225 Views
Last Modified: 2012-05-11
We have had several occurences of this problem, but I can't always reproduce it. When an Outlook 2010 user opens a file attached to a message, they get an error like this:

C:\Documents and Settings\username\Local Settings\Temporary Internet
Files\Content.Outlook\F2E0M??\filename.xls could not be found.  Check the
spelling of the file name, and verify that the file location is correct.

This seems to happen for Excel the most, but we also deal with a lot of Excel files here. After the error, the program for the attachment stays open, but the file is not open. If you go back to the message and double-click the attachment again, it will open.

From what I can tell, this is not the same as the "object not found" that I am finding in my searches, since the program is opening.

I was wondering if anyone has come across this specifically, or has any ideas about the problem. This issue has happened in both XP SP3 and Win7, but always with Outlook 2010.
0
Comment
Question by:Brian B
9 Comments
 
LVL 5

Accepted Solution

by:
skrga earned 375 total points
ID: 34890215
Maybe it has something to do with excel file name, maybe is too big or contains unsupported characters, try to see if it happens with attachments that fit this info..
0
 
LVL 8

Assisted Solution

by:moonie42
moonie42 earned 125 total points
ID: 34890263
I've run into this several times, and deleting the Temporary Internet Files (via the Internet Options control panel) has typically solved the issue.  Those cases where it didn't, it was due to long file names or use of reserved characters in the file name.  If the later is the case, instead of opening the attachment from Outlook, save it to another location (i.e. your desktop, C:\temp, etc.), and then open the file from the new saved location.
0
 
LVL 13

Expert Comment

by:Rick
ID: 34890322
Try this:

Go to the control panel > Folder Options > File Types
Select XLS
Click Advanced > Open entry > Edit
Uncheck "Use DDE"
In the application box add a space then "%1" to the end of that string
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 23

Author Comment

by:Brian B
ID: 34890528
Interesting ideas.

@skgra & @moonie, I would think if the filename was the problem, it wouldn't open the second time either, but stranger things have happened. Although the file I was sent as an example is a long filename.

@rick_gwu, I'll try that for XLS and XLSX, but the problem is I can't reproduce the issue. I would also hate to think this is the global solution as it would mean updating 80 PCs.
0
 
LVL 5

Assisted Solution

by:skrga
skrga earned 375 total points
ID: 34890709
It has happened few times at my fork, filename size (even characters sometime) + path length to temp where outlook stores file when it's opened from mail directly were reasons for that what is bothering you. Insted of dealing with solution for many hours i rather directed clients to save file on some short path (C:\Temp .. or alike) and then open it directly... as moonie42 sad.
0
 
LVL 5

Assisted Solution

by:skrga
skrga earned 375 total points
ID: 34890749
For example in your problem you post path C:\Documents and Settings\username\Local Settings\Temporary Internet Files\Content.Outlook\F2E0M??\filename.xls.

The directory name have ?? in it F2E0M??, windows don't allow ? in folder/filenames, and that specific folder isn't always the target when outlook saves attachement it's "random", so that us why you probobaly dont get error every time - because sometime outlook create path that is ok...
0
 
LVL 23

Author Comment

by:Brian B
ID: 34897735
Actually, the path I used is just an example of the error message I copied from somebody else. Don't know for sure my users' had those question marks.

So it kind of seems like there is no specific solution, just workarounds.
0
 
LVL 23

Author Comment

by:Brian B
ID: 34919232
I didn't mean to accept my own comment as part of the solution. Please correct.
0
 
LVL 23

Author Closing Comment

by:Brian B
ID: 34951201
Thanks for all the help. There was no specific solution, but as a fellow expert I appreciate the effort and it got me looking in the right places.
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Finding original email is quite difficult due to their duplicates. From this article, you will come to know why multiple duplicates of same emails appear and how to delete duplicate emails from Outlook securely and instantly while vital emails remai…
As tax season makes its return, so does the increase in cyber crime and tax refund phishing that comes with it
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question