Solved

Exim - Unrouteable Address

Posted on 2011-02-14
11
1,454 Views
Last Modified: 2012-05-11
I need assistance with using Exim as an SMTP emulator.  I have been all over Google trying to find the answer, but I can't quite find it.

When I run the command of exim -d -bt user@email.com, I get this:
Please note: user@email.com is not the real email address being tested. I made this up only for example purposes

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Testing user@email.com
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Considering user@email.com
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
routing user@email.com
--------> dnslookup router <--------
local_part=user@email.com
checking domains
email.com in "@bc1.la.int"? no (end of list)
email.com in "! +local_domains"? yes (end of list)
calling dnslookup router
dnslookup router called for user@email.com
  domain = user@email.com
DNS lookup of email.com (MX) gave NO_DATA
returning DNS_NODATA
DNS lookup of email.com (AAAA) gave NO_DATA
returning DNS_NODATA
DNS lookup of email.com(A) gave NO_DATA
returning DNS_NODATA
dnslookup router declined for user@email.com
"more" is false: skipping remaining routers
no more routers
user@email.com is undeliverable: Unrouteable address
search_tidyup called
>>>>>>>>>>>>>>>> Exim pid=3820 terminating with rc=2 >>>>>>>>>>>>>>>>

0
Comment
Question by:klewis94
  • 6
  • 5
11 Comments
 
LVL 26

Expert Comment

by:jar3817
ID: 34890622
"DNS lookup of email.com (MX) gave NO_DATA"

The local resolver on that exim server can't get the MX record. Is this your domain or someone elses? If yours, is it loaded in local DNS as well as external?
0
 
LVL 26

Expert Comment

by:jar3817
ID: 34890638
For grins, try changing the local resolver to something public like googles 8.8.8.8 and doing the test again. The nameserver can be set in the /etc/resolv.conf file
0
 

Author Comment

by:klewis94
ID: 34890993
The server is on a subdomain of the mail domain of where, in this example, is email.com

I don't see a resolv.conf file.

In my etc directory, all i have for config files is just exim.conf
0
U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

 

Author Comment

by:klewis94
ID: 34891021
Oops. I meant to say:
The server is on a subdomain of the MAIN domain of where, in this example, is email.com

0
 
LVL 26

Expert Comment

by:jar3817
ID: 34891176
I'm talking about the /etc folder for the whole system, not just for exim. What OS is this system running?
0
 

Author Comment

by:klewis94
ID: 34891185
It is Server 2003.

OK. Got it. I need to modify the system's host file then?
0
 
LVL 26

Expert Comment

by:jar3817
ID: 34891241
Huh? Exim is linux/unix software, how are you running on server 2003?
0
 

Author Comment

by:klewis94
ID: 34891261
No. You can install and run Exim on a Windows environment using what is called Cygwin for Windows.
http://www.cygwin.com/

That is what I am using.
0
 
LVL 26

Accepted Solution

by:
jar3817 earned 500 total points
ID: 34891289
Ok, now I understand what you meant by "SMTP emulator"....

I'm familiar with Cygwin, but never actually used it. Does it inherit the DNS settings from windows or do you specify the settings internally?
0
 

Author Comment

by:klewis94
ID: 34891308
You specify it in the exim.conf file.

But, that's the problem I am having.

If I attempt to send an email to any other email domain it works fine. If I attempt to send the email to my own domain, this it doesn't work.

So, I believe it is something in the exim.conf file.
0
 
LVL 26

Assisted Solution

by:jar3817
jar3817 earned 500 total points
ID: 34891348
Try changing the DNS to something public like 8.8.8.8 and try again. I have a feeling it's an internal/external DNS issue. If you don't have your domain setup properly internally it won't work, but outside servers can send to you because you probably have it setup externally correctly.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Granting full access permission allows users to access mailboxes present in their database. By giving full access permission one can open and read the content of any mailbox but cannot send emails from that mailbox.
The new Gmail Phishing Scam going around is surprising even the savviest of users with its sophisticated techniques.
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…

828 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question