Cannot send mail to existing Exchange 2007 mailbox from Exchange 2010

To All,

I've successfully installed Exchange Server 2010, and I've been able to move mailboxes from my existing Exchange 2007 to the new one. However, I'm not able to send e-mails from 2010 to 2007. On 2010, I can send and receive externally through the Internet, and I'm able to receive internally. I just can't send out to 2007. I've read the following thread and tried the solution.

http://www.experts-exchange.com/Microsoft/Hardware/Q_26713062.html

What happens is that the mail gets stuck in the queue and it dies out after 2 days. I've disabled all the receive connectors except for the Default and Client, and it still doesn't work.
blkburnAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

blkburnAuthor Commented:
It's solved now. The issue was related to the DNS. I just added the FQDN of the 2007 to the hosts file for the 2010 server.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.