Solved

Trunking Cisco 2900 and 4506

Posted on 2011-02-14
16
995 Views
Last Modified: 2012-05-11
I am trying to connect new Cisco 2900 switch to our existing 4506 switch and give access to other vlans.  The new switch will be belong to vlan10. I have configured the following on one of the porst on 4506 and I am going to configure one port on 2900 with the same configuration.  vlan10 is already configure on our core switch and access permission has been set up.

switchport access vlan 10
 switchport trunk encapsulation dot1q
 switchport mode trunk

Once the configuration is done, I have to add all the ports on 2900 to vlan 10, right?

In this case, do I have to use cross-over cable between the two ports or straight through is ok?
0
Comment
Question by:Infamus
  • 7
  • 5
  • 2
  • +2
16 Comments
 
LVL 35

Accepted Solution

by:
Ernie Beek earned 200 total points
ID: 34891333
Correct, all should be (just) accessports on vlan 10.

If I remember correctly the 2900's don't have auto MDI/MDX, so you'll need a cross cable
0
 
LVL 2

Assisted Solution

by:dslam24
dslam24 earned 100 total points
ID: 34892504
You should not need the 'access' command. On the trunk port on your 2900 do this...

switchport trunk encapsulation dot1q (may not be needed on the 2900 because it doesn't do ISL so it's dot1q by default)
switchport mode trunk
switchport trunk allowed vlan 10,x,x,x,x


On the access ports do this...
switchport access vlan 10
switchport mode access



===> then if you want to manage the 2900 using an ip address on vlan10 go
int vlan 10
ip address x.x.x.x <subnet mask>
0
 
LVL 12

Assisted Solution

by:Fidelius
Fidelius earned 100 total points
ID: 34892541
Hello,

If you have 2960 you don't need cross cable. Auto-MDIX is enabled by default.
http://www.cisco.com/en/US/docs/switches/lan/catalyst2960/software/release/12.2_25_see/configuration/guide/swint.html#wp1193977

Regards!
0
 
LVL 12

Author Comment

by:Infamus
ID: 34899183
Thanks for quick replies guys.

So here's what I need to configure on the switch?

On 4506

config t
interface gi5/6
switchport access vlan 10
switchport trunk encapsulation dot1q
switchport mode trunk

On 2900

config t
int vlan10
ip address 10.10.10.1 255.255.255.0

int eth5/3
switchport trunk encapsulation dot1q
switchport mode trunk


Thanks.
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 34899246
Almost, get rid of ' switchport access'.
0
 
LVL 17

Assisted Solution

by:MAG03
MAG03 earned 100 total points
ID: 34899673
if you only want to allow vlan 10 over the trunk then the command would be

On 4506

config t
interface gi5/6
switchport trunk allow vlan 10
switchport trunk encapsulation dot1q
switchport mode trunk


If you are going to allow more than one vlan you can add more vlans to the allow list seperating them with a comma or you can remove the "switchport trunk allow vlan" command all together and all vlans will be allowed by default.
0
 
LVL 12

Author Comment

by:Infamus
ID: 34900444
Thanks, guys.

I will be implementing this on Thursday and I will let you know the result.

I will get back to you once everything is set up.

Thanks again.
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 34900456
Do let us know, good luck.
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 12

Author Comment

by:Infamus
ID: 34929335
Sorry guys, I didn't get a chance to configure the switch yesterday.  It has been scheduled for sometime next week.. Trust me, I won't forget about you guys and will post the result.

Thanks.
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 34930163
We trust you, to post the results ;)
0
 
LVL 12

Author Closing Comment

by:Infamus
ID: 34954445
I haven't tried this yet but I'm sure this will work.
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 34954474
If not, just post here again.

Good luck.
0
 
LVL 12

Author Comment

by:Infamus
ID: 35032858
Okay, that did not work.

Let me clarify by explaining our environment.

We have multiple VLANS but they are able to communicate each other.

Our core switch which is 4507 is the VTP server and the rest of the 4506 switches are VTP clients.

All 4506 switches are directly connected to 4507's Supervisor module.

We added this 2900 switch recently to replace a dummy switch which was plugged into one of the ports one of the 4506s.

VLAN 10 is already defined on the core switch along with other VLANS.

I wasn't able to run some of the commands like switchport mde trunk encap and only options I had were  native, access and prunning.

Any idea?

Thank you.
0
 
LVL 12

Expert Comment

by:Fidelius
ID: 35034960
Hello, if 2900 will have all ports in same VLAN, try to configure it in VTP mode transparent, create manually VLAN 10 and connect it to 4560.

Also please submit IOS version from 2900.

Regards!
0
 
LVL 12

Author Comment

by:Infamus
ID: 35037950
I will try to get the config from the 2900.

Thanks.
0
 
LVL 12

Author Comment

by:Infamus
ID: 35073069
vtp password.....
0

Featured Post

What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

Join & Write a Comment

I see many questions here on Experts Exchange regarding switch port configurations and trunks. This article is meant for beginners in the subject to help to get basic knowledge about Virtual Local Area Network (VLAN (http://en.wikipedia.org/wiki/Vir…
I eventually solved a perplexing problem setting up telnet for a new switch.  I installed a new Cisco WS-03560X-24P switch connected to an existing Cisco 4506 running a WS-X4013-10GE Sup II-Plus. After configuring vlans and trunking,  I could no…
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now