Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1212
  • Last Modified:

cannot access NFS share on Cellera from Server 2008 R2

I am having problems accessing a NFS export on an EMC NX4. I have created the export on the NX4 and can access the NFS export from a VMware server without any issues.

Now I am trying to access the NFS export from a Server 2008 R2 server. I have added the IP address of the 2008 server on the NX4 to allow read/write access.

On the 2008 server, I installed Services for NFS. I have verified that the client for NFS service is running. I can mount the NFS export to a drive in the 2008 server. I can gain read access to the NFS export. However I cannot write anything to the NFS export from the 2008 server.

I have tried mounting the NFS export as the root user, administrative user, and anon (users on the NX4). I have had no luck.

I also enabled the local security policy setting of:
Local Security Policy --> Local Policies --> Security Options --> Network access: Let Everyone permission s apply to anonymous users


Any ideas on what to do? I am sure that this is a permissions issue, most likey located on the 2008 server. I am able to access the NFS share from a VMware host without having to put any log in info. The 2008 server is configured the same was as the VMware host server, in the NX4
0
ryan80
Asked:
ryan80
1 Solution
 
jlevieCommented:
Who is the owner and what are the permissions on the directories in the NFS share (look at them with a Linux/Unix system)?
0
 
ryan80Author Commented:
The owner is root. It has full permissions and the group and others have only read when I look at it from the 2008 server. However I have mounted the NFS export using the user root and still have the same issues.

Also when I mount the NFS export on the VM hosts it can access it fine.

I am not sure how EMC handles permissions for accessing the NFS export, but it is setup by IP address rather than user based. You have to grant the IP read/write, root access.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now