Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 355
  • Last Modified:

Cant connect local Outlook clients to Exchange 2003

I had to format and reinstall Server 2003 Standard along with Exchange 2003 on a server with a crashed hard drive. Upon installing Exchange 2003 I went through all sorts of problems importing the database files but I finally got it and used the mailbox recovery tool to link the mailboxes to each respective new user I created in the AD. Everything is working and mail is flowing, as well as OWA works as well however I cant connect any local clients to the server.

I installed Outlook on the server to test and see if I could connect and it works fine, however LAN clients get the following error when attempting to add the Exchange account. "The action cannot be completed. The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete this action."

I can ping the server fine and all other things like shares work fine. I even tried adding host file entries on the clients to "force" the clients to resolve the name of the server even though they do and still nothing.

I also followed all of the instructions in this article to make sure it wasn't a registry issue.: http://support.microsoft.com/?id=325930

I am all out of ideas at this point.. Anyone have any other suggestions?
0
qbarat2
Asked:
qbarat2
1 Solution
 
Chris PattersonCommented:
Have you tried deleting all the users Outlook profiles on the machines and seeing if a new fresh profile will allow you to connect to the new server?  If you install Outlook on a clean machine, is it able to attach to the new server?  Also have you tried uninstalling Outlook and reinstalling it on a client machine to see if that allows you to attach?
0
 
PostmasterCommented:
It looks like you have changed the mailboxes IDs. So the Outlook profiles do not match the "new" mailboxes. you may need to re-do the Outlook profiles.
0
 
ajaykeralaCommented:
does the OWA work ?

close the outlook and

   1. In Control Panel, open the Mail item.
   2. Click Show Profiles.
   3. Select your profile, and then click Properties.
   4. Click E-mail Accounts.
   5. Select the Microsoft Exchange Server account, and then click Change.
   6. In the dialog box that contains your mailbox server and user name, click More Settings.
   7. In the Microsoft Exchange dialog box, click the Security tab.
   8. Click to select the Encrypt data between Microsoft Office Outlook and Microsoft Exchange check box, and then click OK.
9. click on exchange proxy settings under connection, keyin your exchnage adress and tick the two boxes below "on fast networks.." and on slow network tick both then chnage authentication settings to basic settings click ok.
  10. Click Next, and then click Finish.
  11. Click Close, click Close, and then click OK.
0
NEW Veeam Backup for Microsoft Office 365 1.5

With Office 365, it’s your data and your responsibility to protect it. NEW Veeam Backup for Microsoft Office 365 eliminates the risk of losing access to your Office 365 data.

 
qbarat2Author Commented:
Yes, OWA works. I have tried creating new profiles and still get the same error. I have also tried from 3 different workstations and all are using Outlook 2007. ajaykerala, I tried the steps you mentioned. #8 encryption checkbox was already checked. #9, I tried the following settings:

server name: https://server2
msstd:server2
and all other boxes checked

I'm getting the same error msg when trying with those settings.
0
 
qbarat2Author Commented:
Also, I would like to note again that Outlook installed on the exchange server can connect fine.
0
 
ajaykeralaCommented:
do a tracert from the local pc to the outlook and see if any block
0
 
qbarat2Author Commented:
Here are the tracert results from a client. Looks like it's getting there fine.

Tracing route to server2 [192.168.1.253]
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms  192.168.1.253

Trace complete.
0
 
ajaykeralaCommented:
try connecting using the ip address in the outlook
0
 
qbarat2Author Commented:
Tried that too, same result. I thought about backing up and removing exchange and reinstalling it. What do you think?
0
 
ajaykeralaCommented:
before that can you try to access it from an outside pc ? a pc that is not on the same network ?
0
 
qbarat2Author Commented:
Ok good idea, so I assume you mean test RPC over HTTP functionality? I used testexchangeconnectivity.com and ran the RPC over HTTP test. Everything checked out except one thing.

Testing the SSL certificate to make sure it's valid.
  The SSL certificate failed one or more certificate validation checks.
   Test Steps
   Validating the certificate name.
  The certificate name was validated successfully.
   Additional Details
  Host name ***.***.*** was found in the Certificate Subject Common name.
 
 Certificate trust is being validated.
  Certificate trust validation failed.
   Tell me more about this issue and how to resolve it
   Additional Details
  The certificate chain didn't end in a trusted root. Root = CN=***.***.***

Sorry about the ***, I blocked out the client's personally identifiable information as this information must be kept confidential.
 
 
0
 
qbarat2Author Commented:
By the way, I tested it from outside using RPC and HTTP settings and I get the same result. Not sure if it's happening because of the self signed certificate though...
0
 
qbarat2Author Commented:
Ok, I figured it out. It was a firewall issue. I had entered the proper ports to be opened but I think this still does not work. Even with the firewall off completely I guess it was still causing a block, probably because I had routing and remote access configured and then removed it and started using the Windows firewall.

Only after I ran "scw" (Security Configuration Wizard) and went through the entire security policy configuration procedure did it finally work.
0
 
ajaykeralaCommented:
you have any firefall or router inplace ? have you done al lthe port forwarding for exchnage ?
0
 
qbarat2Author Commented:
After running SCW the problem was instantly fixed. Although firewall was off, it looks like the "Routing and Remote Access" feature was still blocking ports.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now