Solved

Email being delayed

Posted on 2011-02-14
3
1,314 Views
Last Modified: 2012-05-11
I have Small Business Server 2003 running exchange on a local domain (i.e. server.domain.local). I seem to be having an email issue sending email to one particular domain. I get the following delay message:

Final-Recipient: rfc822;xxx@xxxxx.com
Action: delayed
Status: 4.7.1
Diagnostic-Code: smtp;450 4.7.1 <server.domain.local>: Helo command rejected: Host not found
Will-Retry-Until: Tue, 15 Feb 2011 08:55:05 -0700
X-Display-Name: 'xxx@xxxxx.com'

My searches lead me to believe that the receiving email servers may be rejecting (or delaying) email from our domain because the reverse DNS cannot be resolved for the ".local" domain. We are currently using an outside service with DNS and MX records to the server using a ".com" FQDN. This has worked flawlessly for several years, and does not currently affect any other domain email is sent to. Is this a potential cause of the problem, and if so, how can I change the name that the Exchange server supplies in the SMTP header?
0
Comment
Question by:rldewees
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 76

Accepted Solution

by:
Alan Hardisty earned 500 total points
ID: 34893404
It sounds like the FQDN on your SMTP Virtual Server is either configured as internaldomain.local or domain.com and is not resolving properly.

Please have a read of my article and check your configuration:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/A_2427-Problems-sending-mail-to-one-or-more-external-domains.html

The FQDN can be found on your SMTP Virtual Server> Delivery Tab> Advanced Button and should be something like mail.domain.com and this address needs to resolve back to the IP Address that you are sending from in DNS externally from a remote server.

Alan
0
 

Author Comment

by:rldewees
ID: 34893482
When I open IIS Manager, I do not see the SMTP Virtual Server.
0
 

Author Closing Comment

by:rldewees
ID: 34893536
Alan,

The SMTP FQDN seems to have been the culprit. I found the SMTP virtual server in ESM and change the name. Test emails to an external address show the SMTP sender as the correct address now.

Thanks for the help!!!
0

Featured Post

Free eBook: Backup on AWS

Everything you need to know about backup and disaster recovery with AWS, for FREE!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains how to install and use the NTBackup utility that comes with Windows Server.
Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question