HP-UX /opt/aCC/lbin/ecom: Execute permission denied

Posted on 2011-02-14
Last Modified: 2013-12-06
I'm trying to compile cpp code on HP-UX machines. It gave me following errors.
What may be the reason?

Thanks in advance.
root@localhost> uname -ar
HP-UX localhost B.11.23 U ia64 2143951832 unlimited-user license
root@localhost> cat test.cpp 
#include <iostream.h>
int main()
      int x,y;
      cout << "Enter an integer: ";
      cin >> x;
      y = x * 2;
      cout << "\n" << y <<" is twice " << x <<".\n";
root@localhost> make test
        aCC -O test.cpp  -o test
sh: /opt/aCC/lbin/ecom: Execute permission denied.
*** Error exit code 1

root@localhost> ls -ltr /opt/aCC/lbin/ecom
-rwxr-xr-x   1 bin        bin        19089469 Apr 19  2006 /opt/aCC/lbin/ecom

Open in new window

Question by:shanikawm
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
LVL 12

Assisted Solution

trinitrotoluene earned 250 total points
ID: 34894179
here's a reference to a similar problem

looks like it could be due to a security application running ...

Author Comment

ID: 34894350
I coudn't find any such applications  :-(
LVL 34

Assisted Solution

sarabande earned 250 total points
ID: 34895082
try to start ecom from shell

    /opt/aCC/lbin/ecom -help

do you get same error message?

how did you login? from remote?


Accepted Solution

shanikawm earned 0 total points
ID: 34895348
I think the problem is HP-UX doesn't give c++ compiler for free. I download a evaluation version from hp site and installed. Now it's working. But it's only for 60 days.

I'm going to install gcc now.

Earliar /opt/aCC/lbin/ecom -help was giving same error message.

Now it says

/opt/aCC/lbin/ecom -help
Command-line error #2571: invalid option: -help

1 catastrophic error detected in this compilation.
Compilation terminated.


/opt/aCC/lbin/ecom -v
Edison Design Group C/C++ Front End, version 4.1 (Nov 26 2009 22:07:43)
Copyright 1988-2009 Edison Design Group, Inc.

Author Closing Comment

ID: 35187533
Yes. I should buy the compiler

Featured Post

On Demand Webinar: Networking for the Cloud Era

Ready to improve network connectivity? Watch this webinar to learn how SD-WANs and a one-click instant connect tool can boost provisions, deployment, and management of your cloud connection.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

IntroductionThis article is the second in a three part article series on the Visual Studio 2008 Debugger.  It provides tips in setting and using breakpoints. If not familiar with this debugger, you can find a basic introduction in the EE article loc…
Using libpcap/Jpcap to capture and send packets on Solaris version (10/11) Library used: 1.      Libpcap ( Version 1.2 2.      Jpcap( Version 0.6 Prerequisite: 1.      GCC …
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
The goal of the video will be to teach the user the concept of local variables and scope. An example of a locally defined variable will be given as well as an explanation of what scope is in C++. The local variable and concept of scope will be relat…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question