IE8 not browsing the web but will browse any internal network pages

I have a workstation that has a problem in displaying web pages from the Internet, It will browse any pages on our internal Intranet, exchange server or web interface on our router, but will not display any pages from any site outside our location. we can ping any address on the wan or resolve any site to an ip address, we can also trace route any address or web site from the command line,

The browser will display the msn home page after a while but will not move to any other page, I have tried all the fixes around to try to rectify this problem but to no avail, checked for Malware and none found, turned of the AV software.

has anyone got any idea's before i have to flatten the machine and start again with it.

I have also tried to fix the problem with the installation of Firefox but it has the same problems

Seems like the problem happens when we leave the router on our premises
philmc79Asked:
Who is Participating?
 
philmc79Author Commented:
I have stumbled on the solution to the problem.

Some where within the workstation a firewall setting or a reg entry has stopped the machines IP Address from going any further than the internal network, as soon as I gave the machine a static IP address different from that it had received from DHCP server all started working without a hitch, if I went back and gave the machine the same IP address as the DHCP server gave it originally, but static, the outside world browsing stopped yet again, so the solution was to have the machine with an IP Address outside the scope of the DHCP server and make it static

I would like to thank all the people who gave there opinions as to where the fault was but beleve me guy's I had tried them all out and to no avail.

If any of you could point me in the direction of where the ban on the IP address to the WAN can be found i would be only to grateful to award you the points

By the way I forgot to mention the O/S in use is windows 7 Pro fully patched
0
 
Marcus MartinSystem Support OfficerCommented:
Something is blocking http port 80. Check your firewall settings.
0
 
Marcus MartinSystem Support OfficerCommented:
To be more helpful, try an nslookup from the command line and see if dns is resolving correctly.

nslookup www.microsoft.com = 65.55.12.249 from my location.

Check your network settings ensure that the IP, subnet mask and gateway are all set correctly.
Check your hosts file see if theres any thing in there that shouldnt be.

Is there a firewall between you and the external router? if so which one.

0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

 
philmc79Author Commented:
Nothing blocking port 80 as the internal HTTP works fine to the intranet

nslookup works fine as well get an address of 207.46.131.43 from here, and there is no firewall as i have disabled all of these to check if that its the problem, i can get the browser to display the msn home page and google home page but click a link and you get IE cannot display this page and if you type a direct url you get the same massage

0
 
Marcus MartinSystem Support OfficerCommented:
Do you proxy your requests to the internet ?
0
 
cranakisCommented:
Here is what I would try:

From Control Panel - Internet Options - security tab - reset all zones to default level
........................................................... - connections tab - make sure no vpn is setup
............................................................ ........................... - Lan Settings - make sure no proxy is selected
........................................................... - programs tab - manage add ons - disable all add ons
........................................................... - advanced tab- restore advanced settings

if none of the above work:
.................................................................................... - Reset IE Settings - Reset

Good luck

Brandon GIlmer
Network Operations Center Tech
Sago Networks
0
 
philmc79Author Commented:
Found the solution by my self by trial and error and not checking DNS was correctly being issued by the DHCP
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.