• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 7221
  • Last Modified:

PXE-E53: No boot filename received

Hello,

I've followed a guide (http://www.windows-noob.com/forums/index.php?/topic/511-how-can-i-deploy-windows-vista-sp1-using-sccm-2007-sp1/) on how to configure the PXE in SCCM 2007 and I've followed it step by step (except for MDT config) however when I try PXE booting, I get the error..

PXE-E53: No boot filename received

My boot images have been uploaded to the distribution points and assigned to a task sequence which is being advertised to a collection.

Any idea what the problem could be? I'm guessing the client isn't recognizing a boot file so there is a communication break-down somewhere..

The guide I followed didn't say anything about adding DHCP options and I'm guessing I need to but I'm not sure what their values should be?
0
AdamBock
Asked:
AdamBock
  • 4
  • 3
  • 2
  • +1
2 Solutions
 
KezziCommented:
did you distribute the x64 and x86 sccm boot images to the server share name and not the server name distribution point?
0
 
Abduljalil Abou AlzahabInfrastructure Team Leader – Professional ServicesCommented:
To resolve this issue, try to configure the routers IP helper table to contain the IP address of the PXE (ConfigMgr) server.
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
AdamBockAuthor Commented:
did you distribute the x64 and x86 sccm boot images to the server share name and not the server name distribution point?

Not quite sure what you mean sorry.. basically I added two boot wims (see attachment) which were located at..
\\Rapture\sms_was\OSD\boot\i386\boot.wim
\\Rapture\sms_was\OSD\boot\x64\boot.wim
I then uploaded them to the distribution point, is there anything else I still need to do?

The instructions I followed on windows-noob didn't mention anything about configuring port 067 in DHCP server options. Is this something that HAS to be configured in order for PXE to detect a boot file? if so.. what should I specify as the filename (the pxe boot file is located at D:\RemoteInstall\SMSBoot\x86\pxeboot.com)?

Do I have to configure IP helpers? My set up is pretty simple.. using DHCP in windows.. I've used WDS before and everything worked alright without them. I'm not sure where I'd even configure it (I'm using a Billion Bipac 7300N).

Thanks for everyones help!
boots.png
0
 
Abduljalil Abou AlzahabInfrastructure Team Leader – Professional ServicesCommented:
If you like to follow windows-noob article, I recommend to follow the updated one, please check the following link:
http://www.windows-noob.com/forums/index.php?/topic/667-deploy-windows-7/

regarding boot image, expand boot image -> go to distribution point -> check both distribution points
servername and servername\SMSPXEIMAGES
then update distribution points

you need IP helper if you are using multiple VLANS
0
 
AdamBockAuthor Commented:
If you like to follow windows-noob article, I recommend to follow the updated one, please check the following link:
http://www.windows-noob.com/forums/index.php?/topic/667-deploy-windows-7/

Thanks for that, I will follow that thoroughly.. I understand adding boot images/OS etc but what should I follow in order to set up the PXE? I'm very grey in this area and it's unclear how WDS/SCCM/DHCP should work together in order to network boot into a wim.
0
 
Abduljalil Abou AlzahabInfrastructure Team Leader – Professional ServicesCommented:
Please check the following:

How to Initiate Operating System Image Deployments Using PXE
http://technet.microsoft.com/en-us/library/bb693950.aspx

By default, the Configuration Manager 2007 PXE service point is configured to respond immediately to network PXE requests.
in WDS configure PXE response setting as the following:
1- Don't respond to any client computer
2- PXE Response delay to 1 sec

You can use default boot image with ConfigMgr, just add it to required distribution point
0
 
bwoodallCommented:
How to Configure Your Network for OS Deployment
•  Any switch/router that has a DHCP helper configured a PXE helper that points to the server that will be running the PXE role in SCCM will also need to be added.
•  Enable Port Fast on all switch access ports DO NOT ENABLE PORT FAST ON ANY GIG UPLINKS AS THIS WILL CAUSE A INFINITE NETWORK LOOP
•  In DHCP Global Server Options 066 Boot Server Host Name (IP Address of PXE Role Server) and 067 Bootfile Name (pxeboot.com) will need to be added.

0
 
AdamBockAuthor Commented:
all sorted :)
0
 
AdamBockAuthor Commented:
(thanks everyone) :D
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 4
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now